Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] exporting PATH ineffective for finding MPI
From: Ross Boylan (ross_at_[hidden])
Date: 2014-03-14 21:58:28


On 3/14/2014 5:42 PM, Ralph Castain wrote:
> Why not skip some of these problems and configure OMPI --enable-orterun-prefix-by-default?
Cool. Thanks for the pointer. If MPI is compiled with that option, can
it be overridden by the command line?
That is, will orterun --prefix /a/b cause /a/b or the original config
argument to be searched?

Probably doesn't matter too much since I don't want to chance moving the
files after make install....
Ross
>
> On Mar 14, 2014, at 5:14 PM, Ross Boylan <ross_at_[hidden]> wrote:
>
>> I used this script to launch mpi:
>>
>> R_PROFILE_USER=~/KHC/sunbelt/Rmpiprofile LD_LIBRARY_PATH=/home/ross/install/lib:$LD_LIBRARY_PATH PATH=/home/ross/install/bin:/home/ross/install/lib64/R/bin:$PATH orterun -x R_PROFILE_USER -x LD_LIBRARY_PATH \
>> -x PATH -hostfile ~/KHC/sunbelt/hosts -np 18 R --no-save -q
>>
>> For each remote node I get a message like
>> [n11:07642] Error: unknown option "--tree-spawn"
>>
>> According to previous exchanges on this list that is a sign that the remote nodes are picking up the old system version of MPI instead of my new local one. Apparently the PATH values I exported are not used; presumably it's the same for LD_LIBRARY_PATH.
>>
>> I found this surprising.
>>
>> RTFM disclosed the --prefix argument to orterun, and that seems to do the trick.
>>
>> Am I missing anything?
>>
>> Ross Boylan
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users