Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] exporting PATH ineffective for finding MPI
From: Ralph Castain (rhc_at_[hidden])
Date: 2014-03-14 20:42:32


Why not skip some of these problems and configure OMPI --enable-orterun-prefix-by-default?

On Mar 14, 2014, at 5:14 PM, Ross Boylan <ross_at_[hidden]> wrote:

> I used this script to launch mpi:
>
> R_PROFILE_USER=~/KHC/sunbelt/Rmpiprofile LD_LIBRARY_PATH=/home/ross/install/lib:$LD_LIBRARY_PATH PATH=/home/ross/install/bin:/home/ross/install/lib64/R/bin:$PATH orterun -x R_PROFILE_USER -x LD_LIBRARY_PATH \
> -x PATH -hostfile ~/KHC/sunbelt/hosts -np 18 R --no-save -q
>
> For each remote node I get a message like
> [n11:07642] Error: unknown option "--tree-spawn"
>
> According to previous exchanges on this list that is a sign that the remote nodes are picking up the old system version of MPI instead of my new local one. Apparently the PATH values I exported are not used; presumably it's the same for LD_LIBRARY_PATH.
>
> I found this surprising.
>
> RTFM disclosed the --prefix argument to orterun, and that seems to do the trick.
>
> Am I missing anything?
>
> Ross Boylan
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users