Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] incorrect verbose output in bind_downwards
From: Ralph Castain (rhc_at_[hidden])
Date: 2014-03-10 12:08:24


I fear that would be a bad thing to do as it would disrupt mpirun's operations. However, I did fix the problem by adding the topology as a param to the pretty-print functions. Please see:

https://svn.open-mpi.org/trac/ompi/ticket/4356

Thanks for pointing it out
Ralph

On Mar 10, 2014, at 1:15 AM, tmishima_at_[hidden] wrote:

>
> Hi Ralph, I would report one more small thing.
>
> The verbose output in bind_downwards sometimes gives incorrect binding-map
> when I use heterogeneous nodes with different topologies. I confirmed that
> this patch fixed the problem:
>
> --- rmaps_base_binding.c 2014-03-06 12:08:17 +0900
> +++ rmaps_base_binding.try.c 2014-03-07 18:27:42 +0900
> @@ -322,6 +322,7 @@
> hwloc_bitmap_list_asprintf(&proc->cpu_bitmap, totalcpuset);
> if (4 < opal_output_get_verbosity
> (orte_rmaps_base_framework.framework_output)) {
> char tmp1[1024], tmp2[1024];
> + opal_hwloc_topology = node->topology;
> if (OPAL_ERR_NOT_BOUND == opal_hwloc_base_cset2str(tmp1,
> sizeof(tmp1), totalcpuset)) {
> opal_output(orte_rmaps_base_framework.framework_output,
> "%s PROC %s ON %s IS NOT BOUND",
>
> Tetsuya Mishima
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users