Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] bind-to core warning even with numactl
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-03-04 10:03:38

Did you rebuild / re-install Open MPI after these packages were installed? I believe that the assumption is that Open MPI didn't find the headers / libraries it needed to do the binding when it was built.

If that still didn't solve your issue, please send all the information listed here:

On Mar 4, 2014, at 6:57 AM, Saliya Ekanayake <esaliya_at_[hidden]> wrote:

> Hi,
> In an earlier thread I mentioned getting the following error when trying --bind-to core option with mpirun. I was told that numactl and numactl-devel need to be installed. The sys admins have installed these in our cluster and I've rebuilt OpenMPI, but I still get the same warning. I wonder if there's anything more I need to do.
> WARNING: a request was made to bind a process. While the system
> supports binding the process itself, at least one node does NOT
> support binding memory to the process location.
> Node:
> This is a warning only; your job will continue, though performance may
> be degraded.
> Thank you,
> Saliya
> --
> Saliya Ekanayake esaliya_at_[hidden]
> Cell 812-391-4914 Home 812-961-6383
> _______________________________________________
> users mailing list
> users_at_[hidden]

Jeff Squyres
For corporate legal information go to: