Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Compiling Open MPI 1.7.4 using PGI 14.2 and Mellanox HCOLL enabled
From: Filippo Spiga (spiga.filippo_at_[hidden])
Date: 2014-02-25 18:22:46


Dear all,

I came across another small issue while I was compiling Open MPI 1.7.4 using PGI 14.2 and building the support for Mellanox Hierarchical Collectives (--with-hcoll). Here you how configure Open MPI:

export MXM_DIR=/opt/mellanox/mxm
export KNEM_DIR=$(find /opt -maxdepth 1 -type d -name "knem*" -print0)
export FCA_DIR=/opt/mellanox/fca
export HCOLL_DIR=/opt/mellanox/hcoll

../configure CC=pgcc CXX=pgCC FC=pgf90 F90=pgf90 --prefix=/usr/local/Cluster-Users/fs395/openmpi-1.7.4/pgi-14.2_cuda-6.0RC --enable-mpirun-prefix-by-default --with-hcoll=$HCOLL_DIR --with-fca=$FCA_DIR --with-mxm=$MXM_DIR --with-knem=$KNEM_DIR --with-slurm=/usr/local/Cluster-Apps/slurm --with-cuda=$CUDA_INSTALL_PATH

At some point the compile process fails with this error:

make[2]: Leaving directory `/home/fs395/archive/openmpi-1.7.4/build/ompi/mca/coll/hierarch'
Making all in mca/coll/hcoll
make[2]: Entering directory `/home/fs395/archive/openmpi-1.7.4/build/ompi/mca/coll/hcoll'
  CC coll_hcoll_module.lo
  CC coll_hcoll_component.lo
  CC coll_hcoll_rte.lo
  CC coll_hcoll_ops.lo
  CCLD mca_coll_hcoll.la
pgcc-Error-Unknown switch: -pthread
make[2]: *** [mca_coll_hcoll.la] Error 1
make[2]: Leaving directory `/home/fs395/archive/openmpi-1.7.4/build/ompi/mca/coll/hcoll'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/fs395/archive/openmpi-1.7.4/build/ompi'
make: *** [all-recursive] Error 1

Attached the configure.log and the make.log collected as reported on the website. Using google I found an old post referring to the same problem. Here few relevant links:
http://www.open-mpi.org/community/lists/users/2009/03/8687.php
http://www.open-mpi.org/community/lists/users/2010/09/14229.php
http://www.open-mpi.org/community/lists/users/2009/04/8911.php

I have no problem to use a fake wrapper or the "-noswitcherror" compiler pgf90 flag. I wonder if this procedure will affect in some way the MPI built and I have to carry on this flag also when I compile my applications.

Is there any way to fix libtool so Open MPI can build itself properly?

Thanks
Filippo

--
Mr. Filippo SPIGA, M.Sc.
http://www.linkedin.com/in/filippospiga ~ skype: filippo.spiga
«Nobody will drive us out of Cantor's paradise.» ~ David Hilbert
*****
Disclaimer: "Please note this message and any attachments are CONFIDENTIAL and may be privileged or otherwise protected from disclosure. The contents are not to be disclosed to anyone other than the addressee. Unauthorized recipients are requested to preserve this confidentiality and to advise the sender immediately of any error in transmission."