Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OrangeFS ROMIO support
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-02-25 09:05:20


Thanks!

On Feb 25, 2014, at 8:45 AM, Edgar Gabriel <gabriel_at_[hidden]> wrote:

> give me day ( I am currently out of town) to dig up the patch again, and
> reapply it again to the trunk, we can CMR it to 1.6 and 1.7. I did not
> follow up at that time, since nobody else seemed to care. I guess the
> number of users using the combination of OPen MPI + ROMIO + PVFS2 is
> pretty low.
>
> Thanks
> Edgar
>
> On 2/25/2014 7:34 AM, Jeff Squyres (jsquyres) wrote:
>> Edgar --
>>
>> Is there a fix that we should CMR to the v1.6 branch?
>>
>>
>> On Feb 25, 2014, at 8:26 AM, Edgar Gabriel <gabriel_at_[hidden]> wrote:
>>
>>> this was/is a bug in ROMIO, in which they assume a datatype is an int. I
>>> fixed it originally in a previous version of Open MPI on the trunk, but
>>> it did not get ported upstream, so we might have to do the same fix again.
>>>
>>> Thanks
>>> Edgar
>>>
>>> On 2/25/2014 7:15 AM, vithanousek wrote:
>>>> Hello,
>>>>
>>>> At fisrt, please, excuse my poor level of english.
>>>>
>>>> I'm little bit confused by versions of OpenMPI and ROMIO, because i met
>>>> siliar bugs reported in multiple versions. Im buliding version 1.6.5
>>>> (current stable).
>>>>
>>>> I compiled OpenMPI 1.6.5 with included ROMIO by doing this:
>>>>
>>>> ./configure --prefix=/usr/local/openmpi_1.6.5_romio \
>>>> --with-io-romio-flags='--with-pvfs2=/usr/local/orangefs'
>>>> make -j 32
>>>>
>>>> and I got error message:
>>>> (...)
>>>> ad_pvfs2_io_dtype.c: In function 'convert_named':
>>>> ad_pvfs2_io_dtype.c:581: error: switch quantity not an integer
>>>> ad_pvfs2_io_dtype.c:583: error: pointers are not permitted as case values
>>>> (...)
>>>>
>>>> I rewrited "switch" construction to multiple "if" constructions. This
>>>> solve compiling problem.
>>>> But I cant use myself edited source code of OpenMPI on our cluster.
>>>> Is this bug of sourcecode and will be fixed, or am I doing something wrong?
>>>>
>>>> Thanks for reply
>>>> Hanousek Vít
>>>>
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>>
>>> --
>>> Edgar Gabriel
>>> Associate Professor
>>> Parallel Software Technologies Lab http://pstl.cs.uh.edu
>>> Department of Computer Science University of Houston
>>> Philip G. Hoffman Hall, Room 524 Houston, TX-77204, USA
>>> Tel: +1 (713) 743-3857 Fax: +1 (713) 743-3335
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>
> --
> Edgar Gabriel
> Associate Professor
> Parallel Software Technologies Lab http://pstl.cs.uh.edu
> Department of Computer Science University of Houston
> Philip G. Hoffman Hall, Room 524 Houston, TX-77204, USA
> Tel: +1 (713) 743-3857 Fax: +1 (713) 743-3335
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/