Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] one more problem with process bindings
From: Siegmar Gross (Siegmar.Gross_at_[hidden])
Date: 2014-02-09 15:42:06


Hi,

I have one more problem with process bindings (both machines use
Solaris 10 with Sparc processors).

tyr hello_1 149 which mpicc
/usr/local/openmpi-1.7.4_64_cc/bin/mpicc
tyr hello_1 150 mpicc environ_mpi.c
tyr hello_1 151 mpiexec -np 2 --host rs1 a.out
tyr hello_1 152

Do you have any ideas about the reason, why I don't get any output?
I have no problem with openmpi-1.6.5 as you can see below.

tyr hello_1 107 which mpicc
/usr/local/openmpi-1.6.5_64_cc/bin/mpicc
tyr hello_1 108 mpicc environ_mpi.c
tyr hello_1 109 mpiexec -np 2 --host rs1 a.out

Now 1 slave tasks are sending their environment.
Environment from task 1:
  message type: 3
  msg length: 3655 characters
  message:
    hostname: rs1.informatik.hs-fulda.de
    operating system: SunOS
    release: 5.10
    processor: sun4u
    PATH
...

Thank you very much for any help in advance.

Kind regards

Siegmar