Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMpi installation
From: Reuti (reuti_at_[hidden])
Date: 2014-02-07 12:05:12


Hi,

Am 07.02.2014 um 17:42 schrieb Talla:

> I downloaded openmpi 1.7 and followed the installation instructions:
> cd openmpi
> ./configure --prefix="/home/$USER/.openmpi"
>
> make
> make install
> export PATH="$PATH:/home/$USER/.openmpi/bin"
> export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/home/$USER/.openmpi/lib/"
>
> echo export PATH="$PATH:/home/$USER/.openmpi/bin" >> /home/$USER/.bashrc
> echo export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/home/$USER/.openmpi/lib/"
> >> /home/$USER/.bashrc

The ~/.bashrc is by default only sourced for a non-interactive login. Do you have access to the command when you source it by hand?

-- Reuti

NB: To avoid getting any system wide `mpicc`... first, it's safer to specify your custom installation first in both assignments of the environment variables.

> No error messages appear, accept "nothing to do with all-em". However when I run mpicc or mpirun it says no command. So I am not sure if the mpi installed correctly in my red hat server or not. I don't know what I am missing so I would really appreciate it if you help me as I am struggling with this for a while.
>
> Thank you in advance. Talla
>
>
>
> --
> ######################
> Dr. Jamal A Talla
> Assistant professor
> Department of Physics, Rm 2139
> College of Science,09
> King Faisal University
> P.O. Box 380, Al-Ahsaa - 31982
> City Code: HOF
> Kingdom of Saudi Arabia
> Cell Phone: +966564542399
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users