Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] GNU 4.8.x and (no) mpi_f08 module
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-02-06 06:09:12


On Feb 6, 2014, at 4:09 AM, Christoph Niethammer <niethammer_at_[hidden]> wrote:

> I am wondering if it is possible to get a working mpi_f08 module with Open MPI >=1.7.4 and GNU 4.8.x compiler.

It is not, sorry.

> Unfortunately configure (without additional options beside --prefix) decides to not build the mpi_f08 module:
>
> configure:56605: checking if building Fortran 'use mpi' bindings
> configure:56608: result: yes
> configure:57983: checking if building Fortran 'use mpi_f08' bindings
> configure:57990: result: no
>
> With Intel 14 the mpi_f08 module is build correctly.

Correct.

The short version is that gfortran <= v4.8 does not contain enough F08 support to support the mpi_f08 module. More detail can be found in the README:

    https://svn.open-mpi.org/trac/ompi/browser/branches/v1.7/README#L322

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/