Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] opal_os_dirpath_create: Error: Unable to create the, sub-directory
From: Eric Chamberland (Eric.Chamberland_at_[hidden])
Date: 2014-02-03 12:41:56


Hi,

with OpenMPI 1.6.3 I have encountered this error which "randomly" appears:

[compile:20089] opal_os_dirpath_create: Error: Unable to create the
sub-directory (/tmp/openmpi-sessions-cmpbib_at_compile_0/55528/0) of
(/tmp/openmpi-sessions-cmpbib_at_compile_0/55528/0/0), mkdir failed [1]
[compile:20089] [[55528,0],0] ORTE_ERROR_LOG: Error in file
util/session_dir.c at line 106

(view full stderr attached)

and also this mostly same one:

[compile:22876] opal_os_dirpath_create: Error: Unable to create the
sub-directory (/tmp/openmpi-sessions-cmpbib_at_compile_0/53197/0) of
(/tmp/openmpi-sessions-cmpbib_at_compile_0/53197/0/0), mkdir failed [1]
...

Looking deeper, I have found this in /tmp:

ls -ladtr /tmp/openmpi-sessions-cmpbib\@compile_0/* |grep -v "drwx"
-rw-r--r-- 1 cmpbib bib 93 Jan 31 06:47
/tmp/openmpi-sessions-cmpbib_at_compile_0/55528
-rw-r--r-- 1 cmpbib bib 92 Jan 31 06:48
/tmp/openmpi-sessions-cmpbib_at_compile_0/41437
-rw-r--r-- 1 cmpbib bib 93 Jan 31 07:01
/tmp/openmpi-sessions-cmpbib_at_compile_0/59324
-rw-r--r-- 1 cmpbib bib 92 Jan 31 09:49
/tmp/openmpi-sessions-cmpbib_at_compile_0/53197
-rw-r--r-- 1 cmpbib bib 93 Jan 31 11:10
/tmp/openmpi-sessions-cmpbib_at_compile_0/54532
-rw-r--r-- 1 cmpbib bib 93 Jan 31 14:18
/tmp/openmpi-sessions-cmpbib_at_compile_0/36511
-rw-r--r-- 1 cmpbib bib 93 Feb 1 18:50
/tmp/openmpi-sessions-cmpbib_at_compile_0/63980

So there are some *files* in /tmp which are named like the directories
which are tried to be created....

The content of the file /tmp/openmpi-sessions-cmpbib_at_compile_0/55528 is:

4016963584.0;tcp://10.1.1.46:51427;tcp://132.203.7.103:51427;tcp://192.168.122.1:51427
31231

which looks like the content of the file "contact.txt" which seems to
appear in a successfully created directory. Also, the files have been
created far before the executions which aborted...

So, is this a bug in 1.6.3 and is there a "solution" for that?
(I know I can cleanup the files, but I expect OpenMPI to not try to
create a directory if a file with the same name exists...)

Thanks,

Eric