Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Can't build openmpi-1.6.5 with latest FCA 2.5 release.
From: Mike Dubman (miked_at_[hidden])
Date: 2014-01-31 09:06:53


Hi,
Can it be that libibmad/libibumad installed on your system belongs to
previous mofed installation?

Thanks
M.
On Jan 31, 2014 2:02 AM, "Brock Palen" <brockp_at_[hidden]> wrote:

> I grabbed the latest FCA release from Mellnox's website. We have been
> building against FCA 2.5 for a while, but it never worked right. Today I
> tried to build against the latest (version number was still 2.5, but I
> think we have updated our OFED sense the last install). We are running
> MOFED 1.5.3-4.0.42
>
> 1.6.5 configures fine against the old 2.5 fca library I have around (don't
> recall what OFED it expected) but the new one, which claims is for RHEL6.4
> OFED 1.5.3-4.0.42, fails in configure with:
>
> /home/software/rhel6/fca/2.5-v2/lib/libfca.so: undefined reference to
> `smp_mkey_set_at_IBMAD_1.3'
>
> libibmad is installed, but the symbol smp_mkey_set is not defined in it.
> IBMAD_1.3 is though.
>
> Any thought what may cause this? As far as I know our MOFED is from
> Mellnox and should match up fine to their release of FCA. So this has me
> scratching my head.
>
> Thanks
>
> Brock Palen
> www.umich.edu/~brockp
> CAEN Advanced Computing
> XSEDE Campus Champion
> brockp_at_[hidden]
> (734)936-1985
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>