Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI 1.7.2-2.1.3 does not work with OpenFOAM 2.2.2 on OpenSUSE 13.1
From: Dave Love (d.love_at_[hidden])
Date: 2014-01-28 12:24:41


Elisabeth Beer <elisabethbeer_at_[hidden]> writes:

> Hi,
>
> I've done an operating system up-grade to OpenSUSE 13.1 and I've up-graded OpenFOAM from 2.2.1 to 2.2.2.
>
> Bevor, OpenMPI worked well.
> Now, it does not work at all.
>
> First Step
> ------------------
>
> After decomposing the domain, I've tried to start parallel computation:
> mpirun -np 8 simpleFoam -parallel
>
> I've received that error message:
> It looks like opal_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during opal_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> opal_shmem_base_select failed
> --> Returned value -1 instead of OPAL_SUCCESS

I'm fairly sure that is due to mixing up OMPI versions somehow, even if
you tried not to. A user here compiled their own version (actually OF
1.7, but I don't think that's relevant) and got that error when using a
thirdparty directory with OMPI 1.4 in it.

I built an RPM of it against the system OMPI (1.6, but again I'd be
surprised if that matters) and a scotch package with no thirdparty
stuff, and it works. I didn't find out what was actually happening with
the user's version, I'm afraid.

For what it's worth, the spec file for the OF 2.2.2 RPM for RH6 is at
<http://arc.liv.ac.uk/downloads/misc/SPECS/openfoam.spec>. It will need
changes for SuSE which I'd be happy to have before trying to get various
packaging into Fedora/EPEL.

-- 
Community Grid Engine:  http://arc.liv.ac.uk/SGE/