Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi 1.7.4rc1 and f08 interface
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-01-27 10:31:45


We *do* still have a problem in the mpi_f08 module that we probably won't fix before 1.7.4 is released. Here's the ticket:

    https://svn.open-mpi.org/trac/ompi/ticket/4157

Craig has a suggested patch, but a) I haven't had time to investigate it yet, and b) we believe that, at least so far, this issue only affects the as-yet unreleased gfortran 4.9 compiler.

All that being said, my limited Fortran knowledge is probably showing here: is this the same issue that you're reporting with the ekopath compiler?

If so, what version of the ekopath compiler are you using?

On Jan 27, 2014, at 10:00 AM, Åke Sandgren <ake.sandgren_at_[hidden]> wrote:

> On 01/27/2014 03:46 PM, Jeff Squyres (jsquyres) wrote:
>> There has been a LOT of changes in the Fortran since we made rc1; we should probably make rc2.
>>
>> In the meantime, can you try with the latest 1.7 nightly snapshot?
>>
>> http://www.open-mpi.org/nightly/v1.7/
>
> That piece of the code looks the same in that version.
> And I get the same error.
>
> --
> Ake Sandgren, HPC2N, Umea University, S-90187 Umea, Sweden
> Internet: ake_at_[hidden] Phone: +46 90 7866134 Fax: +46 90 7866126
> Mobile: +46 70 7716134 WWW: http://www.hpc2n.umu.se
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/