Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] CXX=no in config.status, breaks mpic++ wrapper
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-01-16 13:52:05


Jed --

Yes, you're right. This is something Brian bugged me about a few months ago, and I'm sorry to say that it hasn't bubbled up high enough in my priority list to look into yet. :-\

The issue is that we decided to stop building the MPI C++ bindings by default on the trunk (this does not, and will not, affect v1.7/v1.7 -- the C++ bindings are still built by default over there). We need to decouple the decision to build the C++ bindings from setting up the C++ wrapper compiler, and that just hasn't been done yet.

A workaround for now is to --enable-mpi-cxx, which will setup the MPI C++ bindings and setup the mpicxx wrapper compiler properly.

On Jan 14, 2014, at 7:33 PM, Jed Brown <jedbrown_at_[hidden]> wrote:

> With ompi-git from Monday (7e023a4ebf1aeaa530f79027d00c1bdc16b215fd),
> configure is putting "compiler=no" in
> ompi/tools/wrappers/mpic++-wrapper-data.txt:
>
> # There can be multiple blocks of configuration data, chosen by
> # compiler flags (using the compiler_args key to chose which block
> # should be activated. This can be useful for multilib builds. See the
> # multilib page at:
> # https://svn.open-mpi.org/trac/ompi/wiki/compilerwrapper3264
> # for more information.
>
> project=Open MPI
> project_short=OMPI
> version=1.9a1
> language=C++
> compiler_env=CXX
> compiler_flags_env=CXXFLAGS
> compiler=no
> preprocessor_flags=
> compiler_flags_prefix=
> compiler_flags=-pthread
> linker_flags= -Wl,-rpath -Wl,@{libdir} -Wl,--enable-new-dtags
> # Note that per https://svn.open-mpi.org/trac/ompi/ticket/3422, we
> # intentionally only link in the MPI libraries (ORTE, OPAL, etc. are
> # pulled in implicitly) because we intend MPI applications to only use
> # the MPI API.
> libs= -lmpi
> libs_static= -lmpi -lopen-rte -lopen-pal -lm -lnuma -lpciaccess -ldl
> dyn_lib_file=libmpi.so
> static_lib_file=libmpi.a
> required_file=
> includedir=${includedir}
> libdir=${libdir}
>
>
> This breaks the wrapper:
>
> $ /path/to/mpic++
> --------------------------------------------------------------------------
> The Open MPI wrapper compiler was unable to find the specified compiler
> no in your PATH.
>
> Note that this compiler was either specified at configure time or in
> one of several possible environment variables.
> --------------------------------------------------------------------------
>
>
> Attaching logs because it's not obvious to me what is going wrong.
> Automake-1.14.1 and autoconf-2.69.
>
> <config.log.xz><config.status.xz>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/