Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] report for openmpi-1.9a1r30290
From: Siegmar Gross (Siegmar.Gross_at_[hidden])
Date: 2014-01-15 07:09:42


Hi,

today I installed openmpi-1.9a1r30290 on "Solaris 10 x86_64",
"Solaris 10 Sparc", and "openSUSE Linux 12.1 x86_64" with Sun C
5.12 and gcc-4.8.0 in 32- and 64-bit. I could successfully build
everything and simple tests on one machine work fine. Even
"ompi_info --all" works fine now on Solaris Sparc. Thank you
very much to everybody who solved the problems and especially
to Jeff, who found the reason for the SIGBUS error, so that
it could be solved.

"make check" reports a problem for the 32-bit version for both
"cc" and "gcc".

linpc1 openmpi-1.9a1r30290-Linux.x86_64.32_cc 115 tail -14 \
  log.make-check.Linux.x86_64.32_cc

SUPPORT: OMPI Test failed: opal_path_nfs() (1 of 22 failed)
FAIL: opal_path_nfs
========================================================
1 of 2 tests failed
Please report to http://www.open-mpi.org/community/help/
========================================================
make[3]: *** [check-TESTS] Error 1
make[3]: Leaving directory
  `.../openmpi-1.9a1r30290-Linux.x86_64.32_cc/test/util'
...

This problem was solved earlier for the 64-bit version.

linpc1 openmpi-1.9a1r30290-Linux.x86_64.64_cc 117 tail -14 \
  log.make-check.Linux.x86_64.64_cc
SUPPORT: OMPI Test Passed: opal_path_nfs(): (22 tests)
PASS: opal_path_nfs
==================
All 2 tests passed
==================
make[3]: Leaving directory
  `.../openmpi-1.9a1r30290-Linux.x86_64.64_cc/test/util'
...

Kind regards

Siegmar