Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] CXX=no in config.status, breaks mpic++ wrapper
From: Jed Brown (jedbrown_at_[hidden])
Date: 2014-01-14 19:33:22


With ompi-git from Monday (7e023a4ebf1aeaa530f79027d00c1bdc16b215fd),
configure is putting "compiler=no" in
ompi/tools/wrappers/mpic++-wrapper-data.txt:

# There can be multiple blocks of configuration data, chosen by
# compiler flags (using the compiler_args key to chose which block
# should be activated. This can be useful for multilib builds. See the
# multilib page at:
# https://svn.open-mpi.org/trac/ompi/wiki/compilerwrapper3264
# for more information.

project=Open MPI
project_short=OMPI
version=1.9a1
language=C++
compiler_env=CXX
compiler_flags_env=CXXFLAGS
compiler=no
preprocessor_flags=
compiler_flags_prefix=
compiler_flags=-pthread
linker_flags= -Wl,-rpath -Wl,@{libdir} -Wl,--enable-new-dtags
# Note that per https://svn.open-mpi.org/trac/ompi/ticket/3422, we
# intentionally only link in the MPI libraries (ORTE, OPAL, etc. are
# pulled in implicitly) because we intend MPI applications to only use
# the MPI API.
libs= -lmpi
libs_static= -lmpi -lopen-rte -lopen-pal -lm -lnuma -lpciaccess -ldl
dyn_lib_file=libmpi.so
static_lib_file=libmpi.a
required_file=
includedir=${includedir}
libdir=${libdir}

This breaks the wrapper:

$ /path/to/mpic++
--------------------------------------------------------------------------
The Open MPI wrapper compiler was unable to find the specified compiler
no in your PATH.

Note that this compiler was either specified at configure time or in
one of several possible environment variables.
--------------------------------------------------------------------------

Attaching logs because it's not obvious to me what is going wrong.
Automake-1.14.1 and autoconf-2.69.






  • application/pgp-signature attachment: stored