Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Bug in my code or in v1.4.3?
From: David Froger (david.froger_at_[hidden])
Date: 2014-01-10 09:44:38


Thanks for the reply.

> The test code looks ok to me.

Ok!

> I will mention that Open MPI 1.4.3 is *very* old; it is now 2 generations behind the current. The current stable release is 1.6.5, and the current feature series (1.7.x) is likely to transition to stable (1.8.x) in a few months. I don't follow Ubuntu at all, but I guess I'm a bit surprised that a) they're so far out of date, and b) they don't even have the last release of the Open MPI 1.4.x series (which was 1.4.5, released Feb 14, 2012).

I'm surprised too, Ubuntu 12.04 is a "Long Term Support" version, supported
until 2017 [1], but the most recent OpenMPI version in the official repository is
1.4.3 [2].

> So yes, it could be a bug in Open MPI -- it's really hard to say with a version that old. I would say that the first step is upgrading to at least Open MPI 1.4.5 -- 1.6.5, if possible.

Ok, so I think we will install 1.6.5 from sources. I just hope 1.4.3 was not
really highlighting a bug in our code!

Thanks for your help,
David

[1] https://wiki.ubuntu.com/LTS
[2] https://launchpad.net/ubuntu/precise/+source/openmpi