Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Failing to MPI run on my linux cluster
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-01-08 11:39:48


It sounds like you are having filesystem permission issues -- i.e., your app is trying to write to a file that is not writable (i.e., this doesn't sound like an MPI issue).

On Jan 8, 2014, at 11:31 AM, Axel Viðarsson <axelvinna_at_[hidden]> wrote:

> Thanks Ralph, now I can least run the examples.
>
> My app is called FDS or Fire dynamics simulator, if someone is familiar with that or just those errors i am getting then i would appreciate any help.
>
> Thanks
> Axel
>
>
> 2014/1/8 Ralph Castain <rhc_at_[hidden]>
> I can't speak to your app as I don't know what it does. However, you *do* have to compile the example first! :-)
>
> A simple "make" in the examples directory will create all the binaries
>
>
> On Jan 8, 2014, at 7:29 AM, Axel Viðarsson <axelvinna_at_[hidden]> wrote:
>
>> Hey all
>>
>> My cluster consist of 2 workstations with hyper threaded Intel Xeon processors and an old Dell dual core computer to control them.
>> I am failing to mpirun on the cluster.
>>
>> 1.When executing as user
>>
>> [prufa_at_master]$ mpirun -np 16 --hostfile /home/prufa/prufa.mpi_hostfile fds_mpi SST1SV20.fds
>>
>> Process 0 of 15 is running .....
>>
>> forrtl: Permission denied
>> forrtl: severe (9): permission to access file denied, unit 4, file /share/apps/FDS/FDS6/FDS6/
>> Examples/Verkis/FDS6MPI_SST_1STEPVALUES_VEL_20.smv
>>
>> 2. Executing same command
>>
>> forrtl: severe (47): write to READONLY file, unit 4, file /share/apps/FDS/FDS6/FDS6/Examples/Verkis/FDS6MPI_SST_1STEPVALUES_VEL_20.smv
>>
>> 3. When i try one of openmpi examples
>>
>> [prufa_at_master]$ mpirun -np 18 /share/apps/openmpi-1.6.5/
>> examples/hello_c.c
>> --------------------------------------------------------------------------
>> mpirun was unable to launch the specified application as it could not access
>> or execute an executable:
>>
>> Executable: /share/apps/openmpi-1.6.5/examples/hello_c.c
>> Node: w0094.stofa.is
>>
>> while attempting to start process rank 0.
>> --------------------------------------------------------------------------
>> 18 total processes failed to start
>>
>>
>> Please could you guys help me with this problem.
>>
>> Thanks in advance
>>
>> Best regards
>> Axel
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/