Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] open-mpi on Mac OS 10.9 (Mavericks)
From: Meredith, Karl (karl.meredith_at_[hidden])
Date: 2013-11-25 08:25:07


I do have these two environment variables set:

LD_LIBRARY_PATH=/Users/meredithk/tools/openmpi/lib
PATH=/Users/meredithk/tools/openmpi/bin

Running mpirun seems to work fine with a simple command, like hostname:

$ )mpirun -n 2 hostname
meredithk-mac.corp.fmglobal.com
meredithk-mac.corp.fmglobal.com

I am trying to run the simple hello_cxx example from the openmpi distribution, compiled as such:
mpic++ -g hello_cxx.cc -o hello_cxx

It compiles fine, without warning or error. However, when I go to run the example, it stalls on the MPI::Init() command:
mpirun -np 1 hello_cxx
It never errors out or crashes. It simply hangs.

I am using the same mpic++ and mpirun version:
$ )which mpirun
/Users/meredithk/tools/openmpi/bin/mpirun

$ )which mpic++
/Users/meredithk/tools/openmpi/bin/mpic++

Not quite sure what else to check.

Karl

On Nov 23, 2013, at 5:29 PM, Ralph Castain <rhc_at_[hidden]> wrote:

> Strange - I run on Mavericks now without problem. Can you run "mpirun -n 1 hostname"?
>
> You also might want to check your PATH and LD_LIBRARY_PATH to ensure you have the prefix where you installed OMPI 1.6.5 at the front. Mac distributes a very old version of OMPI with its software and you don't want to pick it up by mistake.
>
>
> On Nov 22, 2013, at 1:45 PM, Meredith, Karl <karl.meredith_at_[hidden]> wrote:
>
>> I recently upgraded my 2013 Macbook Pro (Retina display) from 10.8 to 10.9. I downloaded and installed openmpi-1.6.5 and compiled it with gcc 4.8 (gcc installed from macports).
>> openmpi compiled and installed without error.
>>
>> However, when I try to run any of the example test cases, the code gets stuck inside the first MPI::Init() call and never returns.
>>
>> Any thoughts on what might be going wrong?
>>
>> The same install on OS 10.8 works fine and the example test cases run without error.
>>
>> Karl
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users