Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] Problem running on multiple nodes with Java bindings
From: Christoffer Hamberg (christoffer.hamberg_at_[hidden])
Date: 2013-11-10 12:24:32


Hi,

I'm having some strange problems running Open MPI(1.9a1r29559) with Java
bindings on a Calxeda highbank ARM Server running Ubuntu 12.10 (GNU/Linux
3.5.0-43-highbank armv7l).

The problem arises when I try to run a job on more than 3 nodes (I have a
total of 8).
Note: It's the same error for any of the node[0-7].

ubuntu_at_node0:~$ mpirun -np 4 -host node0,node1,node2 hostname
Host key verification failed.

ubuntu_at_node0:~$ mpirun -np 4 -host node0,node1,node2,node3 hostname
node0
node0
node1
node2

and not running the job on the current node also gives Host key
verification failed for only 3 nodes.

ubuntu_at_node0:~$ mpirun -np 4 -host node1,node3,node5 hostname
Host key verification failed.

But not on 2 nodes:
ubuntu_at_node0:~$ mpirun -np 4 -host node1,node3 hostname
node1
node1
node3
node3

I've configured it with the following:
./configure --prefix=/opt/openmpi-1.9-java --without-openib --enable-static
--with-threads=posix --enable-mpi-thread-multiple --enable-mpi-java
--with-jdk-bindir=/usr/lib/jvm/java-7-openjdk-armhf/bin
--with-jdk-headers=/usr/lib/jvm/java-7-openjdk-armhf/include

I have Open MPI 1.6.5 (without Java-binding) installed and it runs without
any problems on all nodes, so there should be no problem with SSH that the
error points to.

Any ideas?

Regards,
Christoffer