Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Conflict between OpenMPI 1.7.3 and libevent
From: Dominique Orban (dominique.orban_at_[hidden])
Date: 2013-11-05 14:00:37


I'm installing in a fresh location and include/event2 is still there. I don't speak configure so I may be doing something wrong. It's enough to change the Makefile.am, isn't it?

Here are my commands:

$ cd /tmp/openmpi-1.7.3  # fresh download
$ cp ../ompi-trunk/opal/mca/event/libevent2021/libevent/include/Makefile.am ./opal/mca/event/libevent2021/libevent/include/
$ ./configure --prefix=/tmp/ompi_install --disable-dependency-tracking --disable-silent-rules --enable-ipv6 --enable-mpi-thread-multiple --without-devel-headers  && make all
$ rm -rf /tmp/ompi_install/*
$ make install
$ ls /tmp/ompi_install/include/event2  # bunch of files in there.

I tried with and without `--without-devel-headers`, same result. Here's my patch:

---
diff --git a/opal/mca/event/libevent2021/libevent/include/Makefile.am b/opal/mca/event/libevent2021/libevent/include/Makefile.am
index 5153db2..0446a17 100644
--- a/opal/mca/event/libevent2021/libevent/include/Makefile.am
+++ b/opal/mca/event/libevent2021/libevent/include/Makefile.am
@@ -38,10 +38,12 @@ EXTRA_SRC = $(EVENT2_EXPORT)
 ## the source header filename to derive the installed header filename.
 ## With nobase_ the installed path is $(includedir)/event2/ev*.h.
 
-if INSTALL_LIBEVENT
-nobase_include_HEADERS =	$(EVENT2_EXPORT)
-nobase_nodist_include_HEADERS = ./event2/event-config.h
-else
-noinst_HEADERS =		$(EVENT2_EXPORT)
-nodist_noinst_HEADERS =		./event2/event-config.h
-endif
+# Open MPI: comment this out, because we don't want these header files
+# installed
+# if INSTALL_LIBEVENT
+# nobase_include_HEADERS =	$(EVENT2_EXPORT)
+# nobase_nodist_include_HEADERS = ./event2/event-config.h
+# else
+# noinst_HEADERS =		$(EVENT2_EXPORT)
+# nodist_noinst_HEADERS =		./event2/event-config.h
+# endif
---
On 5 November, 2013 at 11:05:37 AM, Jeff Squyres (jsquyres) (jsquyres_at_[hidden]) wrote:
>  
> On Nov 5, 2013, at 7:44 AM, Dominique Orban  
> wrote:
>  
> > Thanks for patch. Unless I'm completely confused, it is still  
> not resolving the issue. I downloaded Open-MPI 1.7.3 and replaced  
> the Makefile.am with the one obtained from a fresh svn checkout  
> (I checked that your changes are in there).
> >
> > But `make install` still leaves me with an `event2` subdirectory  
> of `include`. I used the `--without-devel-headers` configure  
> flag to be sure.
>  
> Are you installing over an old install, and "event2" is just left  
> over from a previous installation? We won't remove old stuff  
> from $prefix during "make install".
>  
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/  
>  
>  
-- 
Dominique