Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Deprecated parameter: orte_rsh_agent
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-10-02 16:11:10


Yeah, the new MCA param system was setup to be MPI-3 compliant, and so the params don't show up unless you specify a high enough level. You'll see that plm_rsh_agent is the new (and stable) name as it only impacts the rsh launcher

Ralphs-iMac:svn-trunk rhc$ ompi_info -level 9 --param plm rsh
                 MCA plm: parameter "plm_rsh_num_concurrent" (current value:
                          "128", data source: default, level: 9 dev/all,
                          type: int)
                          How many plm_rsh_agent instances to invoke
                          concurrently (must be > 0)
                 MCA plm: parameter "plm_rsh_force_rsh" (current value:
                          "false", data source: default, level: 9 dev/all,
                          type: bool)
                          Force the launcher to always use rsh
                          Valid values: 0: f|false|disabled, 1:
                          t|true|enabled
                 MCA plm: parameter "plm_rsh_disable_qrsh" (current value:
                          "false", data source: default, level: 9 dev/all,
                          type: bool)
                          Disable the launcher to use qrsh when under the
                          Grid Engine parallel environment
                          Valid values: 0: f|false|disabled, 1:
                          t|true|enabled
                 MCA plm: parameter "plm_rsh_daemonize_qrsh" (current value:
                          "false", data source: default, level: 9 dev/all,
                          type: bool)
                          Daemonize the orted under the Grid Engine parallel
                          environment
                          Valid values: 0: f|false|disabled, 1:
                          t|true|enabled
                 MCA plm: parameter "plm_rsh_disable_llspawn" (current value:
                          "false", data source: default, level: 9 dev/all,
                          type: bool)
                          Disable the use of llspawn when under the
                          LoadLeveler environment
                          Valid values: 0: f|false|disabled, 1:
                          t|true|enabled
                 MCA plm: parameter "plm_rsh_daemonize_llspawn" (current
                          value: "false", data source: default, level: 9
                          dev/all, type: bool)
                          Daemonize the orted when under the LoadLeveler
                          environment
                          Valid values: 0: f|false|disabled, 1:
                          t|true|enabled
                 MCA plm: parameter "plm_rsh_priority" (current value: "10",
                          data source: default, level: 9 dev/all, type: int)
                          Priority of the rsh plm component
                 MCA plm: parameter "plm_rsh_delay" (current value: "", data
                          source: default, level: 9 dev/all, type: string)
                          Delay between invocations of the remote agent
                          (sec[:usec])
                 MCA plm: parameter "plm_rsh_no_tree_spawn" (current value:
                          "false", data source: default, level: 9 dev/all,
                          type: bool)
                          If set to true, do not launch via a tree-based
                          topology
                          Valid values: 0: f|false|disabled, 1:
                          t|true|enabled
                 MCA plm: parameter "plm_rsh_agent" (current value: "ssh :
                          rsh", data source: default, level: 9 dev/all, type:
                          string, synonyms: pls_rsh_agent, orte_rsh_agent)
                          The command used to launch executables on remote
                          nodes (typically either "ssh" or "rsh")
                 MCA plm: parameter "plm_rsh_assume_same_shell" (current
                          value: "true", data source: default, level: 9
                          dev/all, type: bool, synonyms:
                          orte_assume_same_shell)
                          If set to true, assume that the shell on the remote
                          node is the same as the shell on the local node.
                          Otherwise, probe for what the remote shell
                          [default: 1]
                          Valid values: 0: f|false|disabled, 1:
                          t|true|enabled
                 MCA plm: parameter "plm_rsh_pass_environ_mca_params"
                          (current value: "true", data source: default,
                          level: 9 dev/all, type: bool)
                          If set to false, do not include mca params from the
                          environment on the orted cmd line
                          Valid values: 0: f|false|disabled, 1:
                          t|true|enabled

On Oct 2, 2013, at 11:19 AM, Oralee Nudson <onudson_at_[hidden]> wrote:

> This posting discusses "plm_rsh_agent" as being a Deprecated parameter:
> http://www.open-mpi.org/community/lists/users/2010/11/14703.php
>
> We just installed openmpi version 1.7.2 and now we see "orte_rsh_agent" as a Deprecated parameter:
>
> ompi_info --param plm rsh
> --------------------------------------------------------------------------
> A deprecated MCA parameter value was specified in an MCA parameter
> file. Deprecated MCA parameters should be avoided; they may disappear
> in future releases.
>
> Deprecated parameter: orte_rsh_agent
> --------------------------------------------------------------------------
>
> What is the replacement parameter for orte_rsh_agent?
>
>
> Thank you,
> Oralee Nudson
> onudson_at_[hidden]
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users