Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] "make check" hangs on Linux with openmpi-1.6.6a1r29175
From: Siegmar Gross (Siegmar.Gross_at_[hidden])
Date: 2013-09-21 12:51:51


Hi,

today I build openmpi-1.6.6a1r29175 with Sun C 5.12 and gcc-4.8.0
on Linux. Unfortunately "make check" hangs.

linpc1 openmpi-1.6.6a1r29175-Linux.x86_64.32_cc 138
   tail log.make-check.Linux.x86_64.32_cc
"../../../openmpi-1.6.6a1r29175/opal/include/opal/sys/atomic_impl.h",
  line 165: warning: statement not reached
"../../../openmpi-1.6.6a1r29175/opal/include/opal/sys/atomic_impl.h",
  line 190: warning: statement not reached
  CCLD opal_path_nfs
make[3]: Leaving directory
  `/export2/src/openmpi-1.6.6/openmpi-1.6.6a1r29175-Linux.x86_64.32_cc/test/util'
make check-TESTS
make[3]: Entering directory
 `/export2/src/openmpi-1.6.6/openmpi-1.6.6a1r29175-Linux.x86_64.32_cc/test/util'
 Failure : Mismatch: input "/home/fd1026", expected:1 got:0

 Failure : Mismatch: input "/home/fdai2368", expected:1 got:0

I get the following output, when I run the program with gdb.

linpc1 .libs 141 gdb opal_path_nfs
GNU gdb (GDB) SUSE (7.3-41.1.2)
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-suse-linux".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /export2/src/openmpi-1.6.6/openmpi-1.6.6a1r29175-Linux.x86_64.32_gcc/test/util/.libs/opal_path_nfs...done.
(gdb) run
Starting program: /export2/src/openmpi-1.6.6/openmpi-1.6.6a1r29175-Linux.x86_64.32_gcc/test/util/.libs/opal_path_nfs
Missing separate debuginfo for /lib/ld-linux.so.2
Try: zypper install -C "debuginfo(build-id)=39c1043d2fcf5b72a2199cfb765d020b1faeb863"
Missing separate debuginfo for /lib/libdl.so.2
Try: zypper install -C "debuginfo(build-id)=e836358b9da37bddf9adaa7430eb92a0a0b19d16"
Missing separate debuginfo for /lib/librt.so.1
Try: zypper install -C "debuginfo(build-id)=c1cd870bd6083af5996fbb10104d4b65ffde6fd6"
Missing separate debuginfo for /lib/libnsl.so.1
Try: zypper install -C "debuginfo(build-id)=b59a58d3fd5023cd781e4b594313da5933f9886e"
Missing separate debuginfo for /lib/libutil.so.1
Try: zypper install -C "debuginfo(build-id)=9d3744ab88fc1d28542d7aa28a7d16950d09b3a1"
Missing separate debuginfo for /lib/libm.so.6
Try: zypper install -C "debuginfo(build-id)=4ef73322578ad9d7b9bb042f0d8c31aecbd2c52d"
Missing separate debuginfo for /lib/libpthread.so.0
Try: zypper install -C "debuginfo(build-id)=593f40f908f51dd863dc2cf94b9cb76bd0bae3d8"
[Thread debugging using libthread_db enabled]
Missing separate debuginfo for /lib/libc.so.6
Try: zypper install -C "debuginfo(build-id)=782d835f454ecfa3cdd590574b59c139283cf7ea"
Detaching after fork from child process 28228.
 Failure : Mismatch: input "/home/fd1026", expected:1 got:0

 Failure : Mismatch: input "/home/fdai2368", expected:1 got:0

I would be grateful, if somebody can fix the problem. Thank you very much
for any help in advance.

Kind regards

Siegmar