Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] compilation aborted for Handler.cpp (code 2)
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-09-20 11:28:48


I can't tell if this is a busted compiler installation or not. The first error is:

-----
/usr/include/c++/4.6.3/bits/stl_algobase.h(573): error: type name is not allowed
        const bool __simple = (__is_trivial(_ValueType1)
                                            ^
          detected during:
            instantiation of "_BI2 std::__copy_move_backward_a2<_IsMove,_BI1,_BI2>(_BI1, _BI1, _BI2) [with _IsMove=false, _BI1=uint32_t={unsigned int} *, _BI2=uint32_t={unsigned int} *]" at line 625
            instantiation of "_BI2 std::copy_backward(_BI1, _BI1, _BI2) [with _BI1=uint32_t={unsigned int} *, _BI2=uint32_t={unsigned int} *]" at line 315 of "/usr/include/c++/4.6.3/bits/vector.tcc"
            instantiation of "void std::vector<_Tp, _Alloc>::_M_insert_aux(__gnu_cxx::__normal_iterator<std::_Vector_base<_Tp, _Alloc>::_Tp_alloc_type::pointer, std::vector<_Tp, _Alloc>>, const _Tp &) [with _Tp=uint32_t={unsigned int}, _Alloc=std::allocator<uint32_t={unsigned int}>]" at line 834 of "/usr/include/c++/4.6.3/bits/stl_vector.h"
            instantiation of "void std::vector<_Tp, _Alloc>::push_back(const _Tp &) [with _Tp=uint32_t={unsigned int}, _Alloc=std::allocator<uint32_t={unsigned int}>]" at line 42 of "Handler.cpp"
-----

I verified that OMPI 1.6.5 builds fine for me for icpc/13.1.0.146 Build 20130121 on RHEL 6.

Perhaps you have some kind of bad interaction between your icpc installation and your local g++ installation...?

On Sep 18, 2013, at 12:58 PM, Syed Ahsan Ali <ahsanshah01_at_[hidden]> wrote:

> Please find attached again.
>
> On Tue, Sep 17, 2013 at 11:35 AM, Jeff Squyres (jsquyres)
> <jsquyres_at_[hidden]> wrote:
>> On Sep 16, 2013, at 9:00 AM, Syed Ahsan Ali <ahsanshah01_at_[hidden]> wrote:
>>
>>> I am trying to compile openmpi-1.6.5 on fc16.x86_64 with icc and ifort
>>> but getting the subject error. config.out and make.out is attached.
>>> Following command was used for configure
>>>
>>> ./configure CC=icc CXX=icpc FC=ifort F77=ifort F90=ifort
>>> --prefix=/home/openmpi_gfortran -enable-mpi-f90 --enable-mpi-f77 |&
>>> tee config.out
>>
>> I'm sorry; I can't open a .rar file. Can you send the logs compressed with a conventional compression program like gzip, bzip2, or zip?
>>
>> Thanks.
>>
>> --
>> Jeff Squyres
>> jsquyres_at_[hidden]
>> For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> --
> Syed Ahsan Ali Bokhari
> Electronic Engineer (EE)
>
> Research & Development Division
> Pakistan Meteorological Department H-8/4, Islamabad.
> Phone # off +92518358714
> Cell # +923155145014
> <logs.zip>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/