Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Segmentation fault with fresh compilation of 1.7.2
From: Matthieu Brucher (matthieu.brucher_at_[hidden])
Date: 2013-09-19 07:45:13


Hi,

I tried with the latest nightly (well now it may not be the latest
anymore), and orte-info didn't crash. So I'll try again later with my
app.

thanks,

Matthieu

2013/9/15 Matthieu Brucher <matthieu.brucher_at_[hidden]>:
> I can try later this week, yes.
> Thanks
>
> Le 15 sept. 2013 19:09, "Ralph Castain" <rhc_at_[hidden]> a écrit :
>
>> Could you try the current 1.7.3 nightly tarball instead? I don't see a
>> problem there, and I'm wondering if this is something we already fixed. We
>> will be releasing 1.7.3 shortly and it is mostly complete at this time.
>>
>>
>> On Sep 15, 2013, at 10:43 AM, Matthieu Brucher
>> <matthieu.brucher_at_[hidden]> wrote:
>>
>> Yes, ompi_info does not crash.
>>
>> Le 15 sept. 2013 18:05, "Ralph Castain" <rhc_at_[hidden]> a écrit :
>>>
>>> No - out of curiosity, does ompi_info work? I'm wondering if this is
>>> strictly an orte-info problem.
>>>
>>> On Sep 15, 2013, at 10:03 AM, Matthieu Brucher
>>> <matthieu.brucher_at_[hidden]> wrote:
>>>
>>> Just --with-lsf. Perhaps because then it must be launched through lsf?
>>>
>>> Le 15 sept. 2013 18:02, "Ralph Castain" <rhc_at_[hidden]> a écrit :
>>>>
>>>> I'm not entirely sure - I don't see anything that would cause that
>>>> problem in that location. How did you configure this?
>>>>
>>>>
>>>> On Sep 12, 2013, at 3:17 AM, Matthieu Brucher
>>>> <matthieu.brucher_at_[hidden]> wrote:
>>>>
>>>> > Hi,
>>>> >
>>>> > I compiled OpenMPI on a RHEL6 box with LSF support, but when I run
>>>> > sonthing, it crashes. Also orte-info crashes:
>>>> >
>>>> > Package: Open MPI mbrucher_at_[hidden] Distribution
>>>> > Open RTE: 1.7.2
>>>> > Open RTE repo revision: r28673
>>>> > Open RTE release date: Jun 26, 2013
>>>> > OPAL: 1.7.2
>>>> > OPAL repo revision: r28673
>>>> > OPAL release date: Jun 26, 2013
>>>> > Ident string: 1.7.2
>>>> > Prefix: /xxx/mbrucher/openmpi
>>>> > Configured architecture: x86_64-unknown-linux-gnu
>>>> > Configure host: xxx.xxx.com
>>>> > Configured by: mbrucher
>>>> > Configured on: Thu Sep 12 10:22:06 BST 2013
>>>> > Configure host: xxx.xxx.com
>>>> > Built by: mbrucher
>>>> > Built on: Thu Sep 12 10:24:59 BST 2013
>>>> > Built host: xxx.xxx.com
>>>> > C compiler: gcc
>>>> > C compiler absolute: /usr/bin/gcc
>>>> > C compiler family name: GNU
>>>> > C compiler version: 4.4.6
>>>> > Internal debug support: no
>>>> > Memory profiling support: no
>>>> > Memory debugging support: no
>>>> > libltdl support: yes
>>>> > Heterogeneous support: no
>>>> > orterun default --prefix: no
>>>> > MPI_WTIME support: gettimeofday
>>>> > Symbol vis. support: yes
>>>> > FT Checkpoint support: no (checkpoint thread: no)
>>>> > [abgengcluster:45509] *** Process received signal ***
>>>> > [abgengcluster:45509] Signal: Segmentation fault (11)
>>>> > [abgengcluster:45509] Signal code: Address not mapped (1)
>>>> > [abgengcluster:45509] Failing at address: 0xf8
>>>> > [abgengcluster:45509] [ 0] /lib64/libpthread.so.0() [0x3ffc00f4a0]
>>>> > [abgengcluster:45509] [ 1]
>>>> >
>>>> > /xxx/mbrucher/openmpi/lib/libopen-pal.so.5(opal_libevent2019_event_priority_set+0x6f)
>>>> > [0x2aae84a736ef]
>>>> > [abgengcluster:45509] [ 2]
>>>> > /xxx/mbrucher/openmpi/lib/libopen-rte.so.5(orte_iof_base_open+0x31c)
>>>> > [0x2aae847edfbc]
>>>> > [abgengcluster:45509] [ 3] orte-info(orte_info_open_components+0x71f)
>>>> > [0x406b8f]
>>>> > [abgengcluster:45509] [ 4] orte-info(main+0x93d) [0x40450d]
>>>> > [abgengcluster:45509] [ 5] /lib64/libc.so.6(__libc_start_main+0xfd)
>>>> > [0x3ffb81ecdd]
>>>> > [abgengcluster:45509] [ 6] orte-info() [0x403b09]
>>>> > [abgengcluster:45509] *** End of error message ***
>>>> > Segmentation fault (core dumped)
>>>> >
>>>> > Is there something that I missed?
>>>> >
>>>> > Cheers,
>>>> >
>>>> > Matthieu
>>>> > --
>>>> > Information System Engineer, Ph.D.
>>>> > Blog: http://matt.eifelle.com
>>>> > LinkedIn: http://www.linkedin.com/in/matthieubrucher
>>>> > Music band: http://liliejay.com/
>>>> > _______________________________________________
>>>> > users mailing list
>>>> > users_at_[hidden]
>>>> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Information System Engineer, Ph.D.
Blog: http://matt.eifelle.com
LinkedIn: http://www.linkedin.com/in/matthieubrucher
Music band: http://liliejay.com/