Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Error in openmpi-1.9a1r29179
From: Siegmar Gross (Siegmar.Gross_at_[hidden])
Date: 2013-09-17 02:49:14


Hi,

I tried to install openmpi-1.9a1r29179 on "openSuSE Linux 12.1",
"Solaris 10 x86_64", and "Solaris 10 sparc" with "Sun C 5.12" in
64-bit mode. Unfortunately "make" breaks with the same error on
all platforms.

tail -15 log.make.Linux.x86_64.64_cc

  CCLD libshmem_c.la
make[3]: Leaving directory `/export2/src/openmpi-1.9/openmpi-1.9a1r29179-Linux.x86_64.64_cc/oshmem/shmem/c'
make[2]: Leaving directory `/export2/src/openmpi-1.9/openmpi-1.9a1r29179-Linux.x86_64.64_cc/oshmem/shmem/c'
Making all in shmem/fortran
make[2]: Entering directory `/export2/src/openmpi-1.9/openmpi-1.9a1r29179-Linux.x86_64.64_cc/oshmem/shmem/fortran'
  CC start_pes_f.lo
"../../../../openmpi-1.9a1r29179/oshmem/shmem/fortran/start_pes_f.c", line 16: void function cannot return value
"../../../../openmpi-1.9a1r29179/oshmem/shmem/fortran/start_pes_f.c", line 16: void function cannot return value
"../../../../openmpi-1.9a1r29179/oshmem/shmem/fortran/start_pes_f.c", line 16: void function cannot return value
cc: acomp failed for ../../../../openmpi-1.9a1r29179/oshmem/shmem/fortran/start_pes_f.c
make[2]: *** [start_pes_f.lo] Error 1
make[2]: Leaving directory `/export2/src/openmpi-1.9/openmpi-1.9a1r29179-Linux.x86_64.64_cc/oshmem/shmem/fortran'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export2/src/openmpi-1.9/openmpi-1.9a1r29179-Linux.x86_64.64_cc/oshmem'
make: *** [all-recursive] Error 1

I configured with the following command.

../openmpi-1.9a1r29179/configure --prefix=/usr/local/openmpi-1.9_64_cc \
  --libdir=/usr/local/openmpi-1.9_64_cc/lib64 \
  --with-jdk-bindir=/usr/local/jdk1.7.0_07-64/bin \
  --with-jdk-headers=/usr/local/jdk1.7.0_07-64/include \
  JAVA_HOME=/usr/local/jdk1.7.0_07-64 \
  LDFLAGS="-m64" \
  CC="cc" CXX="CC" FC="f95" \
  CFLAGS="-m64" CXXFLAGS="-m64 -library=stlport4" FCFLAGS="-m64" \
  CPP="cpp" CXXCPP="cpp" \
  CPPFLAGS="" CXXCPPFLAGS="" \
  --enable-mpi-cxx \
  --enable-cxx-exceptions \
  --enable-mpi-java \
  --enable-heterogeneous \
  --enable-opal-multi-threads \
  --enable-mpi-thread-multiple \
  --with-threads=posix \
  --with-hwloc=internal \
  --without-verbs \
  --without-udapl \
  --without-sctp \
  --with-wrapper-cflags=-m64 \
  --enable-debug \
  |& tee log.configure.$SYSTEM_ENV.$MACHINE_ENV.64_cc

I would be grateful if somebody can fix the bug. Thank you very
much for any help in advance.

Kind regards

Siegmar