Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] adding library (libmpi_cxx.so.1)
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-09-13 14:11:58


This isn't quit enough information to figure out what's going on. Can you provide all the information listed here:

   http://www.open-mpi.org/community/help/

On Sep 13, 2013, at 7:43 PM, amirreza Hashemi <hashemi_amirreza_at_[hidden]> wrote:

> Hi All,
>
> I have a problem to add a MPI library libmpi_cxx.so.1 to code which I am workign on it, I export the library to LD_LIBRARY_PATH. But whenever I do this, I get this error:
> Fatal error in MPI_Comm_dup: Invalid communicator, error stack:
> MPI_Comm_dup(168): MPI_Comm_dup(comm=0x0, new_comm=0x7fff39826eac) failed
> MPI_Comm_dup(96).: Invalid communicator
>
> It might be possible that I have several openmpi in my linux machine and the code could not recognize right one. I just have this library in these two path: /usr/lib64/openmpi/lib/ and /usr/local/lib/, but none of them is not working in my case. Installed openmpi in my machine is openmpi-1.5.4-3.fc16.x86_64 and I am working with Fedora.
> Does anybody can help me to figure out this problem?
>
> Thanks,
> Ami
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/