Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun tries to ssh to local machine
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-08-29 09:32:27


It's quite possible that you've *installed* Open MPI, but you haven't added it to your PATH/LD_LIBRARY_PATH, so "which mpicc" (and friends) won't find them.

See http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path, for example.

On Aug 29, 2013, at 9:30 AM, Federico Carotenuto <carotenuto_at_[hidden]> wrote:

> That's really weird: I know that mpirun works (at least the old mpirun coming with PGI's compiler's MPICH1), and I've make installed the new Openmp 1.6.5. I've installed it in a custom folder (under /home/Software/) so it may be that it's not a path in which the OS looks for the MPI libraries: should I set some environmental variable and/or source commands for pointing the bash shell to the installed Openmp?
>
> Ralph Castain <rhc_at_[hidden]> ha scritto:
>
>> Given what you report, you don't even have MPI installed on your machine. The output you provided indicates that no mpicc and no mpiexec have been installed on your machine, and so none of the MPI implementations have actually been installed.
>>
>>
>> On Aug 29, 2013, at 2:49 AM, Reuti <reuti_at_[hidden]> wrote:
>>
>>> Am 29.08.2013 um 10:41 schrieb Federico Carotenuto:
>>>
>>>> Kind Reuti,
>>>>
>>>> the output of which mpicc is that such program may be found in various packages (which can be installed with apt-get), while which mpiexec outputs nothing (goes back to the prompt).
>>>
>>> You can compile and install Open MPI directly from source - even without being root. You are not limited to what the distribution offers at all.
>>>
>>> -- Reuti
>>>
>>>
>>>> Seems like no mpicc and mpiexec are set on the system...
>>>>
>>>>
>>>> Reuti <reuti_at_[hidden]> ha scritto:
>>>>
>>>>> Hi,
>>>>>
>>>>> Am 26.08.2013 um 18:10 schrieb Federico Carotenuto:
>>>>>
>>>>>> Kind Reuti,
>>>>>>
>>>>>> as you suggested I proceeded to install Openmpi 1.6.5
>>>>>
>>>>> Good.
>>>>>
>>>>>
>>>>>> and changed the environmental variable MPI_ROOT
>>>>>
>>>>> No, there is no such variable necessary to be set (at least from Open MPI points of view).
>>>>>
>>>>>
>>>>>> to the new folder, should I know source the commands in .bashrc to be sure to be able to execute the right mpirun and mpiexec (something like source
>>>>>
>>>>> Please check with:
>>>>>
>>>>> which mpicc
>>>>> which mpiexec
>>>>>
>>>>> which you are using. It's also necessary to recompile the application with the new MPI library.
>>>>>
>>>>> -- Reuti
>>>>>
>>>>>
>>>>>> /home/modelstation/Software/openmpi1.6.5/mpirun, where the directory is the installation directory)?
>>>>>>
>>>>>> Thanks!
>>>>>>
>>>>>> Reuti <reuti_at_[hidden]> ha scritto:
>>>>>>
>>>>>>> Am 26.08.2013 um 14:33 schrieb Federico Carotenuto:
>>>>>>>
>>>>>>>> Kind Reuti,
>>>>>>>>
>>>>>>>> I'm start thinking I've got some compilation issue with MPI: I'm afraid I've got the MPICH 1 coming with the PGI compiler installation, because if I try to run mpiexec the terminal answers with "The program 'mpiexec' can be found in the following packages: *lam-runtime *mpich2 *openmpi-bin *openmpi1.6-bin. Try: sudo apt-get install <selected package>".
>>>>>>>>
>>>>>>>> I've also tried to modify the machinefile that comes by default under /opt/pgi/linux86-64/13.4/mpi/mpich/share/machinefile.LINUX adding the line "modelstation:8", but still mpirun prompts for the password 8 times.
>>>>>>>
>>>>>>> This was normal at that time: one rsh/ssh per parallel instance. Nowadays Open MPI and MPICH2/3 will use only one `rsh`/`ssh` per host and start all other parallel tasks as thread (i.e: on a local machine they don't need a local `rsh` or `ssh` at all). Although you could either adjust `rsh` to disregard passwords (deprecated) or route `rsh` to `ssh` and enable passphraseless login:
>>>>>>>
>>>>>>> MPICH(1) is outdated (released 2005) and I suggested already to Portland to exclude it from the package. IMO this adds more confusion than it help.
>>>>>>>
>>>>>>> Hence, please install a recent version of Open MPI or MPICH2/3 and then we can look into it again on the appropriate list.
>>>>>>>
>>>>>>> -- Reuti
>>>>>>>
>>>>>>> PS: The above mentioned LAM/MPI is outdated too.
>>>>>>>
>>>>>>>
>>>>>>>> Thanks for your help and patience
>>>>>>>>
>>>>>>>>
>>>>>>>> Reuti <reuti_at_[hidden]> ha scritto:
>>>>>>>>
>>>>>>>>> Am 26.08.2013 um 12:53 schrieb Federico Carotenuto:
>>>>>>>>>
>>>>>>>>>> Kind Reuti,
>>>>>>>>>>
>>>>>>>>>> Thanks for your quick reply!
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> I'm afraid I didn't set a machinefile...that may be the problem: I'm fairly new to MPI and SSH and I'm still quite confused even after reading some tutorials.
>>>>>>>>>
>>>>>>>>> There is a default. But you can also specify it on the command line to test it:
>>>>>>>>>
>>>>>>>>> mpiexec -host modelstation -np 2 mpihello
>>>>>>>>>
>>>>>>>>> -- Reuti
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>> My etc/hosts contains: 127.0.0.1 localhost and 127.0.1.1 modelstation (modelstation is the machine name I was mentioning in the previous mail)
>>>>>>>>>>
>>>>>>>>>> if I type hostname the terminal returns modelstation
>>>>>>>>>>
>>>>>>>>>> Cheers
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Reuti <reuti_at_[hidden]> ha scritto:
>>>>>>>>>>
>>>>>>>>>>> Am 26.08.2013 um 12:15 schrieb Federico Carotenuto:
>>>>>>>>>>>
>>>>>>>>>>>> I'm currently having this issue with mpirun: I want to launch a program only on the cores of the local machine, but every time I run an mpi program it says that the host 127.0.0.1 <local_machine_name> with it's associated key is unkown and asks me if I want to add it to the list of ssh known hosts.
>>>>>>>>>>>>
>>>>>>>>>>>> By chowing/chmodding the .ssh file I was able to permanently add this "host" to the list of known hosts, but my problem is that every program that I try to run ask me to insert a password (the actual local user password) n times where n is equal to the -np parameter (i.e.: if I run the program on 8 cores I receive 8 successive password pronts).
>>>>>>>>>>>>
>>>>>>>>>>>> If I insert the password everything runs fine, but it's quite annoying and I wish to bypass such step: is there a way to have mpirun memorize the password? Or make him understand that the 8 nodes are actually 8 cores on the local machine and not 8 different hosts?
>>>>>>>>>>>
>>>>>>>>>>> Which hostname do you specify in your machinefile?
>>>>>>>>>>> Which hostnames are set in /etc/hosts for your local machine?
>>>>>>>>>>> What is the output of `hostname`? Does it match the one in the machinefile?
>>>>>>>>>>>
>>>>>>>>>>> For systemd there is a new command `hostnamectl --static set-hostname [NAME]` to set it.
>>>>>>>>>>>
>>>>>>>>>>> -- Reuti
>>>>>>>>>>> _______________________________________________
>>>>>>>>>>> users mailing list
>>>>>>>>>>> users_at_[hidden]
>>>>>>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> ----------------------------------------------------------------
>>>>>>>>>> This message was sent using IMP, the Internet Messaging Program.
>>>>>>>>>>
>>>>>>>>>> _______________________________________________
>>>>>>>>>> users mailing list
>>>>>>>>>> users_at_[hidden]
>>>>>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>>>>>
>>>>>>>>> _______________________________________________
>>>>>>>>> users mailing list
>>>>>>>>> users_at_[hidden]
>>>>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> ----------------------------------------------------------------
>>>>>>>> This message was sent using IMP, the Internet Messaging Program.
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> users mailing list
>>>>>>>> users_at_[hidden]
>>>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> users mailing list
>>>>>>> users_at_[hidden]
>>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> ----------------------------------------------------------------
>>>>>> This message was sent using IMP, the Internet Messaging Program.
>>>>>>
>>>>>> _______________________________________________
>>>>>> users mailing list
>>>>>> users_at_[hidden]
>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>
>>>>> _______________________________________________
>>>>> users mailing list
>>>>> users_at_[hidden]
>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>
>>>>
>>>>
>>>>
>>>> ----------------------------------------------------------------
>>>> This message was sent using IMP, the Internet Messaging Program.
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
>
>
> ----------------------------------------------------------------
> This message was sent using IMP, the Internet Messaging Program.
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/