Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun tries to ssh to local machine
From: Federico Carotenuto (carotenuto_at_[hidden])
Date: 2013-08-26 08:33:09


Kind Reuti,

I'm start thinking I've got some compilation issue with MPI: I'm
afraid I've got the MPICH 1 coming with the PGI compiler installation,
because if I try to run mpiexec the terminal answers with "The program
'mpiexec' can be found in the following packages: *lam-runtime *mpich2
*openmpi-bin *openmpi1.6-bin. Try: sudo apt-get install <selected
package>".

I've also tried to modify the machinefile that comes by default under
/opt/pgi/linux86-64/13.4/mpi/mpich/share/machinefile.LINUX adding the
line "modelstation:8", but still mpirun prompts for the password 8
times.

Thanks for your help and patience

Reuti <reuti_at_[hidden]> ha scritto:

> Am 26.08.2013 um 12:53 schrieb Federico Carotenuto:
>
>> Kind Reuti,
>>
>> Thanks for your quick reply!
>>
>>
>> I'm afraid I didn't set a machinefile...that may be the problem:
>> I'm fairly new to MPI and SSH and I'm still quite confused even
>> after reading some tutorials.
>
> There is a default. But you can also specify it on the command line
> to test it:
>
> mpiexec -host modelstation -np 2 mpihello
>
> -- Reuti
>
>
>> My etc/hosts contains: 127.0.0.1 localhost and 127.0.1.1
>> modelstation (modelstation is the machine name I was mentioning in
>> the previous mail)
>>
>> if I type hostname the terminal returns modelstation
>>
>> Cheers
>>
>>
>>
>> Reuti <reuti_at_[hidden]> ha scritto:
>>
>>> Am 26.08.2013 um 12:15 schrieb Federico Carotenuto:
>>>
>>>> I'm currently having this issue with mpirun: I want to launch a
>>>> program only on the cores of the local machine, but every time I
>>>> run an mpi program it says that the host 127.0.0.1
>>>> <local_machine_name> with it's associated key is unkown and asks
>>>> me if I want to add it to the list of ssh known hosts.
>>>>
>>>> By chowing/chmodding the .ssh file I was able to permanently add
>>>> this "host" to the list of known hosts, but my problem is that
>>>> every program that I try to run ask me to insert a password (the
>>>> actual local user password) n times where n is equal to the -np
>>>> parameter (i.e.: if I run the program on 8 cores I receive 8
>>>> successive password pronts).
>>>>
>>>> If I insert the password everything runs fine, but it's quite
>>>> annoying and I wish to bypass such step: is there a way to have
>>>> mpirun memorize the password? Or make him understand that the 8
>>>> nodes are actually 8 cores on the local machine and not 8
>>>> different hosts?
>>>
>>> Which hostname do you specify in your machinefile?
>>> Which hostnames are set in /etc/hosts for your local machine?
>>> What is the output of `hostname`? Does it match the one in the machinefile?
>>>
>>> For systemd there is a new command `hostnamectl --static
>>> set-hostname [NAME]` to set it.
>>>
>>> -- Reuti
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>
>>
>>
>> ----------------------------------------------------------------
>> This message was sent using IMP, the Internet Messaging Program.
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.