Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] mpirun tries to ssh to local machine
From: Federico Carotenuto (carotenuto_at_[hidden])
Date: 2013-08-26 06:53:00


Kind Reuti,

Thanks for your quick reply!

I'm afraid I didn't set a machinefile...that may be the problem: I'm
fairly new to MPI and SSH and I'm still quite confused even after
reading some tutorials.

My etc/hosts contains: 127.0.0.1 localhost and 127.0.1.1 modelstation
(modelstation is the machine name I was mentioning in the previous mail)

if I type hostname the terminal returns modelstation

Cheers

Reuti <reuti_at_[hidden]> ha scritto:

> Am 26.08.2013 um 12:15 schrieb Federico Carotenuto:
>
>> I'm currently having this issue with mpirun: I want to launch a
>> program only on the cores of the local machine, but every time I
>> run an mpi program it says that the host 127.0.0.1
>> <local_machine_name> with it's associated key is unkown and asks me
>> if I want to add it to the list of ssh known hosts.
>>
>> By chowing/chmodding the .ssh file I was able to permanently add
>> this "host" to the list of known hosts, but my problem is that
>> every program that I try to run ask me to insert a password (the
>> actual local user password) n times where n is equal to the -np
>> parameter (i.e.: if I run the program on 8 cores I receive 8
>> successive password pronts).
>>
>> If I insert the password everything runs fine, but it's quite
>> annoying and I wish to bypass such step: is there a way to have
>> mpirun memorize the password? Or make him understand that the 8
>> nodes are actually 8 cores on the local machine and not 8 different
>> hosts?
>
> Which hostname do you specify in your machinefile?
> Which hostnames are set in /etc/hosts for your local machine?
> What is the output of `hostname`? Does it match the one in the machinefile?
>
> For systemd there is a new command `hostnamectl --static
> set-hostname [NAME]` to set it.
>
> -- Reuti
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.