Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Addendum to: Assembler instruction errors for push and pop during make
From: Richard Haney (rfhaney_at_[hidden])
Date: 2013-08-20 20:01:07


Ah! Thanks, Jeff. Here is a link to the relevant zip file "
openmpi-1.6.5_configure_and_make.zip<https://docs.google.com/file/d/0B53THZfOZ1qmY1VtaU5obUtUSDQ/edit?usp=sharing>".
 It contains the modified configure (essentially replacing the compound
"if" statement that assigns
ompi_cv_asm_arch="IA32"
because my "long" is size 4); the replacement is the simply the alternative
assignment that configure would chose if my "long" size were not 4:
ompi_cv_asm_arch="AMD64"

The zip file contains:
configure_modified
config.log openmpi-1.6.5_configure.out (the output of configure executed
from within another script)
make_-j_2.out (the output from the parallel attempt at make), and
make.out--(nonparallel make).out

The make command still does not get past the building of of asm.c in
/openmpi-1.6.5/opal/asm

I ran the nonparallel make to eliminate any confusion over the parallel
creation of object file atomic-asm.o in subdirectory .libs by command
  CPPAS atomic-asm.lo
at the same time that the command
  CC asm.lo
was about to "crash" with lots of warnings and with seemingly uninformative
"Error" messages.

On Tue, Aug 20, 2013 at 2:20 PM, Jeff Squyres (jsquyres) <jsquyres_at_[hidden]
> wrote:

> Google drive?
>
>