Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi-1.7.2 rpm
From: Jonathan Barber (jonathan.barber_at_[hidden])
Date: 2013-08-08 04:01:28


I think you're missing the package "rpm-build", is it installed?

Cheers

On 8 August 2013 05:54, RoboBeans <robobeans_at_[hidden]> wrote:

> Hello everyone, I am trying to create rpm from openmpi source code but
> getting following error. Could someone please point what I am doing wrong?
> I have attached buildrpm.sh and openmpi.spec for your reference. Thanks for
> your time!
>
> # *./buildrpm.sh openmpi-1.7.2.tar.gz*
>
>
> --> Found tarball: openmpi-1.7.2.tar.gz
> --> Found Open MPI version: 1.7.2
> --> Found specfile: openmpi.spec
> grep: /root/.rpmmacros: No such file or directory
> --> Found RPM top dir: /usr/src/redhat
> Problem creating rpms: You do not have a /usr/src/redhat directory
> tree or you do not have write access to the /usr/src/redhat directory
> tree. Please remedy and try again.
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
Jonathan Barber <jonathan.barber_at_[hidden]>