Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI 1.7.2 and CLAPACK libs discovery
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-08-02 11:05:56


Guess I'm confused - I'm not aware of OMPI using CLAPACK. Why would you expect our configure to link to it?

On Aug 1, 2013, at 6:37 AM, gpaulus <gpaulus_at_[hidden]> wrote:

> Hello All:
>
> I'm trying to "configure" OpenMPI 1.7.2 on a 64 bit Linux platform (Scientific Linux 6.4, kernel 2.6.32-358.14.1.el6.x86_64). Configure is able to find clapack.h in /usr/local/include but does not find the library libclapack.so (or libclapack.a) stored in /usr/local/lib64. I have put LDFLAGS="-L/usr/local/lib64" in the configure script, to no avail. I also put /usr/local/lib64 in LD_LIBRARY_PATH at the shell level but to no avail as well; adding an entry in /etc/ld.so.conf.d did not help. Even copying the library to /usr/lib64 did not help configure. And although the header file was found in /usr/local/include, putting the library in /usr/local/lib did not improve things.
>
> I would be grateful to whomever can help me understand the problem.
>
> In attachment:
> gnubuild.bz2: the script invoking configure with all the options
> config.out.bz2: the output of the configure run
>
> Regards,
>
> Guy Paulus
>
> <gnubuild.bz2><config.out.bz2>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users