Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] requirement on ssh when run openmpi
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-07-31 19:23:57


On Jul 31, 2013, at 6:45 PM, meng <qsmeng_at_[hidden]> wrote:

> I install openmpi at /usr/local/openmpi-1.6.5 on both computers. and the two computers now can access each other without passwd required. I set the path and ld_library_path in .bashrc and source it.
> I still get the problems as before. In detail, the problem is as follows:
>
> bash: orted: command not found

This error means that you're not setting the path properly on the remote node for non-interactive sessions. Try this:

    ssh REMOTE_NODE env | grep PATH

I think you'll find that the path for OMPI is not in the output.

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/