Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] UnsatisfiedLinkError - libmpi_java.so.0.0.0
From: Saliya Ekanayake (esaliya_at_[hidden])
Date: 2013-07-25 15:19:17


Thank you. I tested a recent version and it worked.

Saliya

On Tue, Jul 23, 2013 at 2:30 PM, Ralph Castain <rhc_at_[hidden]> wrote:

> I suspect it has fallen stale as the Java bindings are being reworked as
> we speak. I hope to see them committed back to the trunk shortly.
>
>
> On Jul 20, 2013, at 10:01 PM, Saliya Ekanayake <esaliya_at_[hidden]> wrote:
>
> Hi,
>
> I obtained the nightly build openmpi-1.9a1r28881 (on 7/19/13) and built it
> with java enabled using,
>
> ./configure --enable-mpi-java --prefix=/N/u/sekanaya/build
>
> Then I wrote a simple MPI program to print the rank of the process,
> following user guide from http://www.open-mpi.org/papers/mpi-java-spec/
>
> I built my code using mpijavac and then tried running it as,
>
> mpirun -np 2 java Main
>
> where Main is my class name (not in a package) and I was running inside
> the folder containing Main.class.
>
> I get the following error when doing so,
>
> Exception in thread "main" java.lang.UnsatisfiedLinkError:
> /N/u/sekanaya/build/lib/libmpi_java.so.0.0.0:
> /N/u/sekanaya/build/lib/libmpi.so.0: undefined symbol: opal_maffinity_setup
>
>
> Any suggestion on fixing this?
>
> Thank you in advance,
>
> Saliya
>
>
>
> --
> Saliya Ekanayake esaliya_at_[hidden]
> Cell 812-391-4914 Home 812-961-6383
> http://saliya.org
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
Saliya Ekanayake esaliya_at_[hidden]
Cell 812-391-4914 Home 812-961-6383
http://saliya.org