Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] errors testing openmpi1.6.5 ----
From: Yuping Sun (ysun_at_[hidden])
Date: 2013-07-25 14:33:45


Hi Ralph:

Here is what I got:

ls /usr/local/openmpi1.6.5/lib/
libmca_common_sm.a libmpi.a libmpi_cxx.la libmpi_f77.la libmpi_f90.la libompitrace.a libopen-pal.a libopen-rte.a libopen-trace-format.a libotfaux.a libvt.a libvt-hyb.la libvt-mpi.a libvt-mpi-unify.a libvt-mt.a libvt-pomp.a mpi.mod pkgconfig
libmca_common_sm.la libmpi_cxx.a libmpi_f77.a libmpi_f90.a libmpi.la libompitrace.la libopen-pal.la libopen-rte.la libopen-trace-format.la libotfaux.la libvt-hyb.a libvt.la libvt-mpi.la libvt-mpi-unify.la libvt-mt.la libvt-pomp.la openmpi
[root_at_ysunrh usr]#

Do you think I have all the referenced libraries? If yes, then what I need to do?
I also try the following to see my libpath:

[root_at_ysunrh usr]#
[root_at_ysunrh usr]# echo $LD_LIBRARY_PATH

[root_at_ysunrh usr]#

---so I have not set up the library path. What would you suggest me to do?

However, I have /usr/local/openmpi1.6.5/bin in my PATH.

By the way, I also see there is rpm package for openmpi below issuing command:

>yum whatprovides openmpi

openmpi-1.4-4.el5.i386 : Open Message Passing Interface
Repo : rhel-x86_64-server-5
Matched from:

openmpi-1.4-4.el5.x86_64 : Open Message Passing Interface
Repo : rhel-x86_64-server-5
Matched from:

openmpi-1.4-7.el5.i386 : Open Message Passing Interface
Repo : rhel-x86_64-server-5
Matched from:

openmpi-1.4-7.el5.x86_64 : Open Message Passing Interface
Repo : rhel-x86_64-server-5
Matched from:

would you tell me how to install openmpi using yum or rpm? And how to get a rpm package for openmpi-1.6.5.? I installed openmpi-1.6.5 using tar file downloaded from the openmpi.org website.

Thank you.

Thank you.

From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On Behalf Of Ralph Castain
Sent: Wednesday, July 24, 2013 8:35 PM
To: Open MPI Users
Subject: Re: [OMPI users] errors testing openmpi1.6.5 ----

If you list the /usr/local/openmpi1.6.5/lib directory, do you see the referenced libraries?

On Jul 24, 2013, at 5:09 PM, Yuping Sun <ysun_at_[hidden]<mailto:ysun_at_[hidden]>> wrote:

Dear All:

I downloaded openmpi1.5.6 and installed on my linux workstation with the help of NASA engineer. Then I tried to test the openmpi installation, but get the following error message:

[ysun_at_ysunrh mpi]$ which mpiexec
/usr/local/openmpi1.6.5/bin/mpiexec
[ysun_at_ysunrh mpi]$ mpiexec utils/MPIcheck/mpicheck
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24905] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_paffinity_hwloc: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24905] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_carto_auto_detect: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24905] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_carto_file: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24905] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_shmem_mmap: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24905] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_shmem_posix: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24905] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_shmem_sysv: lt_dlerror() returned NULL! (ignored)
--------------------------------------------------------------------------
It looks like opal_init failed for some reason; your parallel process is
likely to abort. There are many reasons that a parallel process can
fail during opal_init; some of which are due to configuration or
environment problems. This failure appears to be an internal failure;
here's some additional information (which may only be relevant to an
Open MPI developer):

  opal_shmem_base_select failed
  --> Returned value -1 instead of OPAL_SUCCESS
--------------------------------------------------------------------------
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24905] [[INVALID],INVALID] ORTE_ERROR_LOG: Error in file runtime/orte_init.c at line 79
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24905] [[INVALID],INVALID] ORTE_ERROR_LOG: Error in file orterun.c at line 694

I also try the use ompi_info to get more information, and it give me a lot error messages and I listed some below:

[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24920] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_osc_pt2pt: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24920] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_osc_rdma: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24920] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_btl_self: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24920] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_btl_sm: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24920] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_btl_tcp: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24920] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_topo_unity: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24920] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_pubsub_orte: lt_dlerror() returned NULL! (ignored)
[ysunrh.fdwt.com<http://ysunrh.fdwt.com>:24920] mca: base: component_find: unable to open /usr/local/openmpi1.6.5/lib/openmpi/mca_dpm_orte: lt_dlerror() returned NULL! (ignored)
           MCA backtrace: execinfo (MCA v2.0, API v2.0, Component v1.6.5)
              MCA memory: linux (MCA v2.0, API v2.0, Component v1.6.5)
               MCA timer: linux (MCA v2.0, API v2.0, Component v1.6.5)
         MCA installdirs: env (MCA v2.0, API v2.0, Component v1.6.5)
         MCA installdirs: config (MCA v2.0, API v2.0, Component v1.6.5)
               MCA hwloc: hwloc132 (MCA v2.0, API v2.0, Component v1.6.5)

Could anyone of you give me some help, and tell me what I need to do to install openmpi correctly or give me some instructions to make it working? Thank you.

Yuping Sun

FloDesign Wind Turbine Corp
242 Sturbridge Road
Charlton, MA 01507
Direct: 508-434-1507
Cell: 713-456-9420
ysun_at_[hidden]<mailto:ysun_at_[hidden]>
<image001.jpg>

_______________________________________________
users mailing list
users_at_[hidden]<mailto:users_at_[hidden]>
http://www.open-mpi.org/mailman/listinfo.cgi/users