Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] libtool:line1128 gfortran command not found
From: meng (qsmeng_at_[hidden])
Date: 2013-07-25 11:24:07


Dear Ralph,
         Thank you for the reply. I have added the path to gcc to .bashrc at $HOME directory and gfortran can run anywhere.
But I did not know what environment has PATH=/usr/bin:/bin. Maybe this is far from the correct way.
  Regards,
meng

At 2013-07-25 21:58:16,"Ralph Castain" <rhc_at_[hidden]> wrote:
you need to add the path to your gcc to your $PATH environment, and then re-run configure

On Jul 25, 2013, at 5:36 AM, meng <qsmeng_at_[hidden]> wrote:

Hi all,
    I am trying to install openmpi and come upone many problems. One is about the Fortran 77 compiler in configure stage, I solved it by editing .bashrc, changing from $GCCHOME/lib to $GCCHOME/lib64. Of course your os should be 64-bits.
  After configure, when running make all install, the screen display:

./scripts/mpi_imrecv_f90.f90.sh /home/greatnet/openmpi-1.7.2/ompi/mpi/fortran/use-mpi-tkr > mpi_imrecv_f90.f90
 ../../../../libtool: line 1128: gfortran: command not found

 However, I am sure that gfortran exists and can run in any directory. When I add "$PATH" after line 1128 in libtool, and then remake, it display "/usr/bin:/bin". Yes, indeed my gcc is not in /usr/bin ,/bin. How to add gcc to that path or how to solve my problem?
 Thank you for your help.
Regards,
Meng
 

_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users