Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] After OS Update MPI_Init fails on one host
From: Kevin H. Hobbs (hobbsk_at_[hidden])
Date: 2013-07-23 10:30:01


On 07/23/2013 06:56 AM, Jeff Squyres (jsquyres) wrote:
> With this embedded mechanism, we're calling hwloc's configury with
> the moral equivalent of:
>
> ./configure --disable-cairo --disable-libxml2 --enable-xml
> --with-hwloc-symbol-prefix=opal_hwloc152_ --enable-embedded-mode

I configured hwloc-1.4.3 with :

./configure \
  --prefix=/opt/hwloc-1.4.3 \
  --disable-cairo \
  --disable-libxml2

I'm left off --with-hwloc-symbol-prefix=opal_hwloc152_ because there
seems to be no way to tell openmpi-1.6.5 about this name mangling.

I left off --enable-embedded-mode because with this option nothing is
installed.

I left off --enable-xml because configure warns :

configure: WARNING: unrecognized options: --enable-xml

I configured openmpi-1.6.5 with :

./configure \
  --prefix=/opt/openmpi-1.6.5_hwloc-1.4.3 \
  --with-hwloc=/opt/hwloc-1.4.3

I built my simple program with :

/opt/openmpi-1.6.5_hwloc-1.4.3/bin/mpicc -g \
  -o mpi_simple mpi_simple.c

and I ran it with :

/opt/openmpi-1.6.5_hwloc-1.4.3/bin/mpirun -n 1 mpi_simple

and got as output "my rank is 0 of 1".

So this the _only_ openmpi build configured with the"--with-hwloc="
option that has worked.