Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] After OS Update MPI_Init fails on one host
From: Kevin H. Hobbs (hobbsk_at_[hidden])
Date: 2013-07-21 08:50:43


On 07/20/2013 04:14 PM, Ralph Castain wrote:
> Ah! That would indicate an issue with the external hwloc
> package they provided, which is the big reason we don't
> recommend installing from packages.

I'll happily report the bug to the hwloc developers.

I'll also add what we've found here to the bug on the Fedora
bugzilla.

Is there anything more I can do on this list to figure out the
nature of the bug?

> We have internal copies of hwloc and libevent that ensure (a)
> they are at the proper level, and (b) they are configured
> properly for OMPI's use.

It does look like Fedora's hwloc is ahead of OMPI's.

Fedora 18 has openmpi-1.6.3 and hwloc-1.4.2.

The source of openmpi-1.6.5 has hwloc-1.3.2.

How can I tell what the configuration differences are?

The entire configure section of the .spec file in
hwloc-1.4.2-2.fc18.src.rpm is :

  %configure
  %{__make} %{?_smp_mflags} V=1

I don't see anything that looks like any hwloc configure options
are being set.

How do I tell how OMPI configures it's bundled hwloc?

> We've had that debate with the Fedora folks recently - they
> won't take our advice,

I admit to having a bias against bundled dependencies, but I
don't want to get in the middle of a debate.

> so I'm afraid you'll just need to build from source to have
> something usable.

Yes, that solves my problem, but if I can I'd like to leave at
least a trail of breadcrumbs that the next person to encounter
the bug can follow.

Better yet, I'd like to figure out the actual nature of the bug
and report it in the proper place.