Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] After OS Update MPI_Init fails on one host
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-07-19 17:11:11


Are you sure you're using the same version of OMPI on this new OS? They typically distribute one in your default path, so I'd check to ensure that you really are using the version you think.

On Jul 19, 2013, at 12:49 PM, "Kevin H. Hobbs" <hobbsk_at_[hidden]> wrote:

> I just upgraded the OS on one of my workstations from Fedora 17 to 18
> and now I can't run even the simplest MPI programs.
>
> I filed a bug report with Fedora's bug tracker :
>
> https://bugzilla.redhat.com/show_bug.cgi?id=986409
>
> My simple program is attached as mpi_simple.c
>
> mpicc works :
>
> mpicc -g -o mpi_simple mpi_simple.c
>
> I can even take the generated program to another computer and it runs fine.
>
> I can run mon MPI programs with mpirun :
>
> mpirun -n 4 hostname
> murron.hobbs-hancock
> murron.hobbs-hancock
> murron.hobbs-hancock
> murron.hobbs-hancock
>
> When I run a program that calls MPI_Init I get an error which includes :
>
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_util_nidmap_init failed
> --> Returned value Error (-1) instead of ORTE_SUCCESS
> --------------------------------------------------------------------------
>
> The output of :
>
> mpirun -n 1 mpi_simple
>
> is attached as error.txt
>
> I suspect it matters that this is a lenovo S10 with what /proc/cpuinfo
> calls a "Intel(R) Core(TM)2 Quad CPU Q6600"
>
> I did a bit of poking around in gdb but I don't know what I'm looking for.
>
> Does anybody have an idea what's going on?
> <mpi_simple.c><error.txt>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users