Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Open MPI 1.6.5 "make all" fails on Win7 with "system cannot find file specified"
From: marco atzeri (marco.atzeri_at_[hidden])
Date: 2013-07-11 06:06:20


Il 7/11/2013 11:15 AM, Don Warren ha scritto:
> Hello, all,
>
> I'm attempting to install Open MPI in a cygwin environment on Windows 7
> (64-bit, but I think Open MPI is treating things like a 32-bit environment).

Hi Don,
cygwin already has a 1.7.1 package

$ cygcheck -c -d |grep mpi
libopenmpi 1.7.1-2
libopenmpi-devel 1.7.1-2
libopenmpicxx1 1.7.1-2
libopenmpifh2 1.7.1-2
libopenmpiuse1 1.7.1-2
openmpi 1.7.1-2

any reason to not use it ?
Any reason to need 1.6.5 ?

Cygwin is 32 bit enviroment, so of coure the package is 32bit;
However cygwin64, still beta, already has the same package version

$ cygcheck -c -d |grep mpi
libopenmpi 1.7.1-2
libopenmpi-devel 1.7.1-2
libopenmpicxx1 1.7.1-2
libopenmpifh2 1.7.1-2
libopenmpiuse1 1.7.1-2
openmpi 1.7.1-2

> The command I used to configure Open MPI was
> -----------------------
> ./configure --with-mpi-f90-size=medium -prefix=/home/Don/openmpi
> F77=gfortran FC=gfortran
> -----------------------

too little ;-)
current 1.7.1-2 package is built with:

         configure \
                 LDFLAGS="-Wl,--export-all-symbols -no-undefined" \
                 --disable-mca-dso \
                 --disable-sysv-shmem \
                 --without-udapl \
                 --enable-cxx-exceptions \
                 --with-threads=posix \
                 --without-cs-fs \
                 --enable-heterogeneous \
                 --with-mpi-param_check=always \
                 --enable-contrib-no-build=vt,libompitrace \
 
--enable-mca-no-build=paffinity,installdirs-windows,timer-windows,shmem-sysv

and I had a similar one on previous 1.6.4-2 package

Regards
MArco