Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Error when build openmpi on Mac Pro
From: Reem Alraddadi (raba500_at_[hidden])
Date: 2013-06-23 12:18:01


Hi Gus,
I did that and I just used this time "make" rather than "make all" but
still this error about "all" I have. I am wondering if this error is vital
or I can just ignore it.

Thanks,
Reem

On 23 June 2013 16:30, Gustavo Correa <gus_at_[hidden]> wrote:

> Hi Reem
>
> You can do a "make distclean" in your build directory first,
> to get rid of any residual of previous builds.
> Or just untar the OMPI tarball again and start fresh.
>
> Then use the regular sequence of "configure ...", "make", "make install",
> to build Open MPI.
>
> I hope this helps,
> Gus Correa
>
> On Jun 23, 2013, at 6:32 AM, Reem Alraddadi wrote:
>
> > Hi Jeff,
> >
> > I fixed the problem with CXX . Thanks, Now, I have only one problem:
> > ''
> > Making all in test
> > Making all in support
> > make[2]: Nothing to be done for `all'.
> > Making all in asm
> > make[2]: Nothing to be done for `all'.
> > Making all in class
> > make[2]: Nothing to be done for `all'.
> > Making all in threads
> > make[2]: Nothing to be done for `all'.
> > Making all in datatype
> > make[2]: Nothing to be done for `all'.
> > Making all in util
> > make[2]: Nothing to be done for `all'.
> > make[2]: Nothing to be done for `all-am'.
> > make[1]: Nothing to be done for `all-am'.
> > '''
> > I don't understand what's it 'all' mean here??
> >
> > Any idea??
> >
> > Reem
> >
> >
> >
> > On 14 June 2013 14:41, Jeff Squyres (jsquyres) <jsquyres_at_[hidden]>
> wrote:
> > Gus picked up the issue properly - you're setting CXX to gcc; it needs
> to be g++.
> >
> > If configure fails with g++, then you have a busted C++ compiler (that's
> a guess; I haven't seen the output from failed configure when uu specify
> CXX=g++). You can disable OMPI's use of C++ with. --disable-MPI-CXX on the
> configure command line.
> >
> > My phone auto corrected MPI and CXX to be caps in the option name;
> > They should be lower case.
> >
> > Sent from my phone. No type good.
> >
> > On Jun 14, 2013, at 5:31 AM, "Reem Alraddadi" <raba500_at_[hidden]>
> wrote:
> >
> >> Hi all,
> >> Jeff -- I am not sure want do you mean by STL but currently I am using
> mpich-3.0.4 with gcc and I don't have any problem. Is there a way to know
> if C++ still works on Mac or not? I am sure that on Mac I use C++ but i
> haven't try to use it before.
> >>
> >> Gus-- I tried to use CXX=g++ but the configure step fail. since gcc has
> C compiler I just switch to gcc.
> >>
> >> Thanks,
> >> Reem
> >>
> >>
> >>
> >> On 13 June 2013 22:13, Gus Correa <gus_at_[hidden]> wrote:
> >> Hi all
> >>
> >>
> >> On 06/13/2013 05:02 PM, Jeff Squyres (jsquyres) wrote:
> >> It looks like you might have a busted C++ compiler.
> >>
> >>
> >> Why not use CXX=g++?
> >> Would this be the problem?
> >>
> >> >> $ export CXX=gcc
> >>
> >> Gus Correa
> >>
> >>
> >>
> >> Can you compile any non-MPI C++ programs that use the STL?
> >>
> >>
> >> On Jun 12, 2013, at 6:58 AM, Reem Alraddadi<raba500_at_[hidden]> wrote:
> >>
> >> Dear all,
> >>
> >> I am trying to build openmpi-1.6.1 on Mac os x version 10.7.5. The
> configuration process goes without any error. However, when I did "make
> all" I got an error:
> >>
> >> std::allocator<std::pair<unsigned int const, unsigned int> > >*)
> constin Stats.o
> >> ld: symbol(s) not found for architecture x86_64
> >> collect2: ld returned 1 exit status
> >> make[9]: *** [otfaux] Error 1
> >> make[8]: *** [all-recursive] Error 1
> >> make[7]: *** [all-recursive] Error 1
> >> make[6]: *** [all] Error 2
> >> make[5]: *** [all-recursive] Error 1
> >> make[4]: *** [all-recursive] Error 1
> >> make[3]: *** [all] Error 2
> >> make[2]: *** [all-recursive] Error 1
> >> make[1]: *** [all-recursive] Error 1
> >> make: *** [all-recursive] Error 1
> >>
> >> you can see the whole make file in attachement. In configure step I
> wrote the following:
> >>
> >> $ export F77=gfortran
> >>
> >> $ export FFLAGS='-m64'
> >>
> >> $ export FC=gfortran
> >>
> >> $ export FCFLAGS='-m64'
> >>
> >> $ export CC=gcc
> >>
> >> $ export CXX=gcc
> >>
> >> $export ARCHFLAGS="-arch x86_64"
> >>
> >> $ ~/Desktop/openmpi-1.6.1/configure
> --prefix=/Users/reemalraddadi/openmpi-install 2>&1 |tee c.txt
> --enable-gfortran -with-gnu-ld -o
> >>
> >>
> >>
> >> I am pretty sure that I use my Mac is 64-bit :
> >>
> >> $ file /usr/lib/libffi.dylib
> >>
> >> /usr/lib/libffi.dylib: Mach-O universal binary with 2
> architectures/usr/lib/libffi.dylib (for architecture x86_64): Mach-O
> 64-bit dynamically linked shared library x86_64
> >> /usr/lib/libffi.dylib (for architecture i386): Mach-O dynamically
> linked shared library i386
> >>
> >> Does anyone has an idea where the wrong is?
> >>
> >>
> >> Thanks,
> >> Reem
> >>
> >> <make output.txt>_______________________________________________
> >> users mailing list
> >> users_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >>
> >>
> >>
> >> _______________________________________________
> >> users mailing list
> >> users_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >>
> >> _______________________________________________
> >> users mailing list
> >> users_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>