Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] error running with mpirun
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-06-21 13:27:02


The ras/proxy plugin hasn't been around in a long, long time -- what version of OMPI are you running?

Regardless, it sounds like a busted Open MPI install. You should wholly re-install OMPI from scratch. Be sure to *uninstall* the prior Open MPI install (which is easiest if you installed it into a standalone directory with nothing else), because installing a new Open MPI version does not remove all the plugins from a prior Open MPI installation.

Make sense?

On Jun 20, 2013, at 4:00 PM, Lorenzo Donà <lorechimica91_at_[hidden]> wrote:

> Dear all that help me: THANKS for your patience with me.
> I was able to compile with open MPI:
> but now I found this error message running programs copiled with open MPI:
>
> A requested component was not found, or was unable to be opened. This
> means that this component is either not installed or is unable to be
> used on your system (e.g., sometimes this means that shared libraries
> that the component requires are unable to be found/loaded). Note that
> Open MPI stopped checking at the first component that it did not find.
>
> Host: MacBook-Pro-di-Lorenzo-Dona.local
> Framework: ras
> Component: proxy
> --------------------------------------------------------------------------
> [MacBook-Pro-di-Lorenzo-Dona.local:34123] [[34784,0],0] ORTE_ERROR_LOG: Error in file ess_hnp_module.c at line 360
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_ras_base_open failed
> --> Returned value Error (-1) instead of ORTE_SUCCESS
> --------------------------------------------------------------------------
> [MacBook-Pro-di-Lorenzo-Dona.local:34122] [[INVALID],INVALID] ORTE_ERROR_LOG: Unable to start a daemon on the local node in file ess_singleton_module.c at line 428
> [MacBook-Pro-di-Lorenzo-Dona.local:34122] [[INVALID],INVALID] ORTE_ERROR_LOG: Unable to start a daemon on the local node in file ess_singleton_module.c at line 211
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_ess_init failed
> --> Returned value Unable to start a daemon on the local node (-127) instead of ORTE_SUCCESS
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> It looks like MPI_INIT failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during MPI_INIT; some of which are due to configuration or environment
> problems. This failure appears to be an internal failure; here's some
> additional information (which may only be relevant to an Open MPI
> developer):
>
> ompi_mpi_init: orte_init failed
> --> Returned "Unable to start a daemon on the local node" (-127) instead of "Success" (0)
> --------------------------------------------------------------------------
> [MacBook-Pro-di-Lorenzo-Dona:34122] *** An error occurred in MPI_Init
> [MacBook-Pro-di-Lorenzo-Dona:34122] *** reported by process [4294967295,4294967295]
> [MacBook-Pro-di-Lorenzo-Dona:34122] *** on a NULL communicator
> [MacBook-Pro-di-Lorenzo-Dona:34122] *** Unknown error
> [MacBook-Pro-di-Lorenzo-Dona:34122] *** MPI_ERRORS_ARE_FATAL (processes in this communicator will now abort,
> [MacBook-Pro-di-Lorenzo-Dona:34122] *** and potentially your MPI job)
> --------------------------------------------------------------------------
> An MPI process is aborting at a time when it cannot guarantee that all
> of its peer processes in the job will be killed properly. You should
> double check that everything has shut down cleanly.
>
> Reason: Before MPI_INIT completed
> Local host: MacBook-Pro-di-Lorenzo-Dona.local
> PID: 34122
> --------------------------------------------------------------------------
> MacBook-Pro-di-Lorenzo-Dona:v1 lorenzodona$ export LD_LIBRARY_PATH=/Users/lorenzodona/Desktop/openmpi-1.7.1/bin/lib:$LD_LIBRARY_PATH
> MacBook-Pro-di-Lorenzo-Dona:v1 lorenzodona$ mpirun -np 1 /Users/lorenzodona/Downloads/abinit-7.2.2/src/98_main/abinit <t4x.files
> --------------------------------------------------------------------------
> A requested component was not found, or was unable to be opened. This
> means that this component is either not installed or is unable to be
> used on your system (e.g., sometimes this means that shared libraries
> that the component requires are unable to be found/loaded). Note that
> Open MPI stopped checking at the first component that it did not find.
>
> Host: MacBook-Pro-di-Lorenzo-Dona.local
> Framework: ras
> Component: proxy
> --------------------------------------------------------------------------
> [MacBook-Pro-di-Lorenzo-Dona.local:34143] [[34804,0],0] ORTE_ERROR_LOG: Error in file ess_hnp_module.c at line 360
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_ras_base_open failed
> --> Returned value Error (-1) instead of ORTE_SUCCESS
> --------------------------------------------------------------------------
> [MacBook-Pro-di-Lorenzo-Dona.local:34142] [[INVALID],INVALID] ORTE_ERROR_LOG: Unable to start a daemon on the local node in file ess_singleton_module.c at line 428
> [MacBook-Pro-di-Lorenzo-Dona.local:34142] [[INVALID],INVALID] ORTE_ERROR_LOG: Unable to start a daemon on the local node in file ess_singleton_module.c at line 211
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_ess_init failed
> --> Returned value Unable to start a daemon on the local node (-127) instead of ORTE_SUCCESS
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> It looks like MPI_INIT failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during MPI_INIT; some of which are due to configuration or environment
> problems. This failure appears to be an internal failure; here's some
> additional information (which may only be relevant to an Open MPI
> developer):
>
> ompi_mpi_init: orte_init failed
> --> Returned "Unable to start a daemon on the local node" (-127) instead of "Success" (0)
> --------------------------------------------------------------------------
> [MacBook-Pro-di-Lorenzo-Dona:34142] *** An error occurred in MPI_Init
> [MacBook-Pro-di-Lorenzo-Dona:34142] *** reported by process [4294967295,4294967295]
> [MacBook-Pro-di-Lorenzo-Dona:34142] *** on a NULL communicator
> [MacBook-Pro-di-Lorenzo-Dona:34142] *** Unknown error
> [MacBook-Pro-di-Lorenzo-Dona:34142] *** MPI_ERRORS_ARE_FATAL (processes in this communicator will now abort,
> [MacBook-Pro-di-Lorenzo-Dona:34142] *** and potentially your MPI job)
> --------------------------------------------------------------------------
> An MPI process is aborting at a time when it cannot guarantee that all
> of its peer processes in the job will be killed properly. You should
> double check that everything has shut down cleanly.
>
> Reason: Before MPI_INIT completed
> Local host: MacBook-Pro-di-Lorenzo-Dona.local
> PID: 34142
> --------------------------------------------------------------------------
> MacBook-Pro-di-Lorenzo-Dona:v1 lorenzodona$ mpirun -np 1 /Users/lorenzodona/Downloads/abinit-7.2.2/src/98_main/abinit <t4x.files
> --------------------------------------------------------------------------
> A requested component was not found, or was unable to be opened. This
> means that this component is either not installed or is unable to be
> used on your system (e.g., sometimes this means that shared libraries
> that the component requires are unable to be found/loaded). Note that
> Open MPI stopped checking at the first component that it did not find.
>
> Host: MacBook-Pro-di-Lorenzo-Dona.local
> Framework: ras
> Component: proxy
> --------------------------------------------------------------------------
> [MacBook-Pro-di-Lorenzo-Dona.local:34148] [[34767,0],0] ORTE_ERROR_LOG: Error in file ess_hnp_module.c at line 360
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_ras_base_open failed
> --> Returned value Error (-1) instead of ORTE_SUCCESS
> --------------------------------------------------------------------------
> [MacBook-Pro-di-Lorenzo-Dona.local:34147] [[INVALID],INVALID] ORTE_ERROR_LOG: Unable to start a daemon on the local node in file ess_singleton_module.c at line 428
> [MacBook-Pro-di-Lorenzo-Dona.local:34147] [[INVALID],INVALID] ORTE_ERROR_LOG: Unable to start a daemon on the local node in file ess_singleton_module.c at line 211
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_ess_init failed
> --> Returned value Unable to start a daemon on the local node (-127) instead of ORTE_SUCCESS
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> It looks like MPI_INIT failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during MPI_INIT; some of which are due to configuration or environment
> problems. This failure appears to be an internal failure; here's some
> additional information (which may only be relevant to an Open MPI
> developer):
>
> ompi_mpi_init: orte_init failed
> --> Returned "Unable to start a daemon on the local node" (-127) instead of "Success" (0)
> --------------------------------------------------------------------------
> [MacBook-Pro-di-Lorenzo-Dona:34147] *** An error occurred in MPI_Init
> [MacBook-Pro-di-Lorenzo-Dona:34147] *** reported by process [4294967295,4294967295]
> [MacBook-Pro-di-Lorenzo-Dona:34147] *** on a NULL communicator
> [MacBook-Pro-di-Lorenzo-Dona:34147] *** Unknown error
> [MacBook-Pro-di-Lorenzo-Dona:34147] *** MPI_ERRORS_ARE_FATAL (processes in this communicator will now abort,
> [MacBook-Pro-di-Lorenzo-Dona:34147] *** and potentially your MPI job)
> --------------------------------------------------------------------------
> An MPI process is aborting at a time when it cannot guarantee that all
> of its peer processes in the job will be killed properly. You should
> double check that everything has shut down cleanly.
>
> Reason: Before MPI_INIT completed
> Local host: MacBook-Pro-di-Lorenzo-Dona.local
> PID: 34147
>
> Can you help me?
> Thans again for your patince and help.
> Dearly lorenzo.
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/