Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi 1.6.3 fails to identify local host if its IP is 127.0.1.1
From: Reuti (reuti_at_[hidden])
Date: 2013-06-19 17:52:36


Am 19.06.2013 um 22:14 schrieb Riccardo Murri:

> On 19 June 2013 20:42, Reuti <reuti_at_[hidden]> wrote:
>> Am 19.06.2013 um 19:43 schrieb Riccardo Murri <riccardo.murri_at_[hidden]>:
>>
>>> On 19 June 2013 16:01, Ralph Castain <rhc_at_[hidden]> wrote:
>>>> How is OMPI picking up this hostfile? It isn't being specified on the cmd line - are you running under some resource manager?
>>>
>>> Via the environment variable `OMPI_MCA_orte_default_hostfile`.
>>>
>>> We're running under SGE, but disable the OMPI/SGE integration (rather

BTW: Which version of SGE?

>>
>> It's disabled by default, you would have to activate it during `configure` of Open MPI.
>
> It's enabled but (IIRC) the problem is that OpenMPI detects the
> presence of SGE from some environment variable

Correct.

> , which, in our version
> of SGE, simply isn't there.

Do you use a custom "starter_method" in the queue definition? Does a submitted script with:

#!/bin/sh
env

list at least some of the SGE* environment variables - or none at all?

-- Reuti

> I can dig up the details if you're interested.
>
> Regards,
> Riccardo
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users