Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] error with openmpi on snow leopard
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-06-19 17:21:02


On Jun 19, 2013, at 4:11 PM, Lorenzo Donà <lorechimica91_at_[hidden]> wrote:

> MacBook-Pro-di-Lorenzo-Dona:bin lorenzodona$ mpif90
> --------------------------------------------------------------------------
> Unfortunately, this installation of Open MPI was not compiled with
> Fortran 90 support. As such, the mpif90 compiler is non-functional.
> --------------------------------------------------------------------------
> but when i type:
> MacBook-Pro-di-Lorenzo-Dona:bin lorenzodona$ ./mpif90
> gfortran: fatal error: no input files

This sounds like you might benefit from taking a Linux shell tutorial.

If you run "foo" and get one error message and run "./foo" and get a different error message, that suggests that you are running two different "foo" executables. For example, it might mean that "foo" is found early in your PATH, and is *not* the "foo" that is in your current working directory. But when you run "./foo", you're forcing the use of the "foo" in your current working directory. It sounds like the former one is broken, but the latter one works.

Gus also noted some good points in his reply.

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/