Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] error with openmpi on snow leopard
From: Gus Correa (gus_at_[hidden])
Date: 2013-06-19 16:27:28


Hi Lorenzo

Did you really use:

>> -prefix=/Users/lorenzodona/Desktop/openmpi-1.7.1/bin

as you say in your email (note the extra "bin" at the end)?

Or did you perhaps use something more common?
Say:

-prefix=/Users/lorenzodona/Desktop/openmpi-1.7.1

Is the extra "bin" sub-directory in your prefix
perhaps causing the problem?

If you really installed in the prefix your email says,
I'd guess your PATH and LD_LIBRARY_PATH would be:

PATH=/Users/lorenzodona/Desktop/openmpi-1.7.1/bin/bin:$PATH

LD_LIBRARY_PATH=/Users/lorenzodona/Desktop/openmpi-1.7.1/bin/lib:$LD_LIBRARY_PATH

Actually, if I remember right, on a Mac,
you need to set DYLD_LIBRARY_PATH,
instead of LD_LIBRARY_PATH, right?

And you need (or already have) X-code installed, right?

Or am I missing something here?

I hope this helps,
Gus Correa

On 06/19/2013 03:37 PM, Ralph Castain wrote:
> you need to put your prefix at the beginning:
>
> PATH=/Users/lorenzodona/Desktop/openmpi-1.7.1/bin:$PATH
> LD_LIBRARY_PATH=/Users/lorenzodona/Desktop/openmpi-1.7.1/lib:$LD_LIBRARY_PATH
>
> then check that you have it correct by
>
> which mpif90
>
>
> On Jun 19, 2013, at 12:31 PM, Lorenzo Donà <lorechimica91_at_[hidden]
> <mailto:lorechimica91_at_[hidden]>> wrote:
>
>> I export PATH=/usr/local/gfortran/bin:$PATH
>> i configured it in this way:
>> ./configure CC=gcc CXX=g++ F77=gfortran FC=gfortran
>> -prefix=/Users/lorenzodona/Desktop/openmpi-1.7.1/bin
>> but the problem is the same
>> after type make i type make check and I passed all the test.
>> when I try to compile a f.90 file with mpif90
>> typing:
>> mpif90 <input.f90 i find an error
>> but when I type
>> ./mpif90 <input.f90 it's work......
>>
>>
>> Il giorno 19/giu/2013, alle ore 21.05, Ralph Castain ha scritto:
>>
>>> what prefix did you give configure? is your path and ld_library_path
>>> set to that location?
>>>
>>> On Jun 19, 2013, at 11:59 AM, Lorenzo Donà <lorechimica91_at_[hidden]
>>> <mailto:lorechimica91_at_[hidden]>> wrote:
>>>
>>>> I have it I used gfortran after configuration I typed ake ckech and
>>>> I passed all the tests
>>>> but when I try to use mpif90 or others mpi compilers I find always
>>>> Cannot open configuration file
>>>> /Users/lorenzodona/Desktop/openmpi-1.7.1/share/openmpi/opal_wrapper-wrapper-data.txt
>>>> Error parsing data file opal_wrapper: Not found
>>>>
>>>> Il giorno 19/giu/2013, alle ore 20.45, Jeff Squyres (jsquyres) ha
>>>> scritto:
>>>>
>>>>> Have a look at the README file; it contains a lot of information
>>>>> about building Open MPI.
>>>>>
>>>>> In short, for F90 support, you want to have a Fortran 90 compiler
>>>>> (E.g., gfortran) in your PATH when you run configure.
>>>>>
>>>>>
>>>>> On Jun 19, 2013, at 2:41 PM, Lorenzo Donà <lorechimica91_at_[hidden]
>>>>> <mailto:lorechimica91_at_[hidden]>> wrote:
>>>>>
>>>>>> configure it with gnu 4.6 without configurations options
>>>>>> when I compile another program this i the message:
>>>>>> Unfortunately, this installation of Open MPI was not compiled with
>>>>>> Fortran 90 support. As such, the mpif90 compiler is non-functional.
>>>>>> can you help me to configure correctly openmpi?
>>>>>> Il giorno 19/giu/2013, alle ore 19.02, Ralph Castain ha scritto:
>>>>>>
>>>>>>> How did you configure it?
>>>>>>>
>>>>>>> On Jun 19, 2013, at 9:26 AM, Lorenzo Donà
>>>>>>> <lorechimica91_at_[hidden] <mailto:lorechimica91_at_[hidden]>> wrote:
>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> Inizio messaggio inoltrato:
>>>>>>>>
>>>>>>>>> Da: Lorenzo Donà <lorechimica91_at_[hidden]
>>>>>>>>> <mailto:lorechimica91_at_[hidden]>>
>>>>>>>>> Data: 19 giugno 2013 18.14.26 GMT+02.00
>>>>>>>>> A: users_at_[hidden] <mailto:users_at_[hidden]>
>>>>>>>>> Oggetto: error with openmpi on snow leopard
>>>>>>>>>
>>>>>>>>> Hi I compiled openmpi v1.7.1 and previous but I always found
>>>>>>>>> this message:
>>>>>>>>> Cannot open configuration file
>>>>>>>>> /Users/lorenzodona/Desktop/openmpi-1.7.1/share/openmpi/opal_wrapper-wrapper-data.txt
>>>>>>>>> Error parsing data file opal_wrapper: Not found
>>>>>>>>> Please can you help me?
>>>>>>>>> Thans for your patience dearly
>>>>>>>>> Lorenzo.
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> users mailing list
>>>>>>>> users_at_[hidden] <mailto:users_at_[hidden]>
>>>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> users mailing list
>>>>>>> users_at_[hidden] <mailto:users_at_[hidden]>
>>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>>
>>>>>> _______________________________________________
>>>>>> users mailing list
>>>>>> users_at_[hidden] <mailto:users_at_[hidden]>
>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>
>>>>>
>>>>> --
>>>>> Jeff Squyres
>>>>> jsquyres_at_[hidden] <mailto:jsquyres_at_[hidden]>
>>>>> For corporate legal information go to:
>>>>> http://www.cisco.com/web/about/doing_business/legal/cri/
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> users mailing list
>>>>> users_at_[hidden] <mailto:users_at_[hidden]>
>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden] <mailto:users_at_[hidden]>
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden] <mailto:users_at_[hidden]>
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden] <mailto:users_at_[hidden]>
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users