Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Error when build openmpi on Mac Pro
From: Gus Correa (gus_at_[hidden])
Date: 2013-06-13 17:13:00


Hi all

On 06/13/2013 05:02 PM, Jeff Squyres (jsquyres) wrote:
> It looks like you might have a busted C++ compiler.
>

Why not use CXX=g++?
Would this be the problem?

>> $ export CXX=gcc

Gus Correa

> Can you compile any non-MPI C++ programs that use the STL?
>
>
> On Jun 12, 2013, at 6:58 AM, Reem Alraddadi<raba500_at_[hidden]> wrote:
>
>> Dear all,
>>
>> I am trying to build openmpi-1.6.1 on Mac os x version 10.7.5. The configuration process goes without any error. However, when I did "make all" I got an error:
>>
>> std::allocator<std::pair<unsigned int const, unsigned int> > >*) constin Stats.o
>> ld: symbol(s) not found for architecture x86_64
>> collect2: ld returned 1 exit status
>> make[9]: *** [otfaux] Error 1
>> make[8]: *** [all-recursive] Error 1
>> make[7]: *** [all-recursive] Error 1
>> make[6]: *** [all] Error 2
>> make[5]: *** [all-recursive] Error 1
>> make[4]: *** [all-recursive] Error 1
>> make[3]: *** [all] Error 2
>> make[2]: *** [all-recursive] Error 1
>> make[1]: *** [all-recursive] Error 1
>> make: *** [all-recursive] Error 1
>>
>> you can see the whole make file in attachement. In configure step I wrote the following:
>>
>> $ export F77=gfortran
>>
>> $ export FFLAGS='-m64'
>>
>> $ export FC=gfortran
>>
>> $ export FCFLAGS='-m64'
>>
>> $ export CC=gcc
>>
>> $ export CXX=gcc
>>
>> $export ARCHFLAGS="-arch x86_64"
>>
>> $ ~/Desktop/openmpi-1.6.1/configure --prefix=/Users/reemalraddadi/openmpi-install 2>&1 |tee c.txt --enable-gfortran -with-gnu-ld -o
>>
>>
>>
>> I am pretty sure that I use my Mac is 64-bit :
>>
>> $ file /usr/lib/libffi.dylib
>>
>> /usr/lib/libffi.dylib: Mach-O universal binary with 2 architectures/usr/lib/libffi.dylib (for architecture x86_64): Mach-O 64-bit dynamically linked shared library x86_64
>> /usr/lib/libffi.dylib (for architecture i386): Mach-O dynamically linked shared library i386
>>
>> Does anyone has an idea where the wrong is?
>>
>>
>> Thanks,
>> Reem
>>
>> <make output.txt>_______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>