Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] problem with -lmpi
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-06-05 14:40:57


I would guess that adding the -lmpi might create an issue as the "mpif90" wrapper already has it in there. Are you adding it for some reason?

On Jun 5, 2013, at 11:03 AM, Florian Beutler <fbeutler_at_[hidden]> wrote:

> Hi
> I just installed openMPI and the installation works without any trouble. But when I want to use the mpif90 compiler, it gives me the following error
>
> bash-3.2$ mpif90 -lmpi
> ld: library not found for -lmpi
>
> I was wondering whether there is a configure flag which I forgot to set? My configure command is
>
> ./configure FC=ifort MPIFC=mpif90 --prefix=/usr/local/openmpi 2>&1 | tee config.out
>
> so I am using the ifort compiler. I attached the output files
>
> I am using mpich-3.0.4 on Mac OS 10.8.2
>
> I set the following paths in my .bashrc file
>
> PATH=/usr/local/openmpi/bin:$PATH ; export PATH
> LD_LIBRARY_PATH=/usr/local/openmpi/lib:$LD_LIBRARY_PATH ; export LD_LIBRARY_PATH
> DYLD_LIBRARY_PATH=$LD_LIBRARY_PATH ; export DYLD_LIBRARY_PATH
>
> any help is highly appreciated
> thanks
> florian
> <config_out.tar.gz><make_out.tar.gz><make-install_out.tar.gz>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users