Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] problem with -lmpi
From: Florian Beutler (fbeutler_at_[hidden])
Date: 2013-06-05 14:03:39

I just installed openMPI and the installation works without any trouble.
But when I want to use the mpif90 compiler, it gives me the following error

bash-3.2$ mpif90 -lmpi
ld: library not found for -lmpi

I was wondering whether there is a configure flag which I forgot to set? My
configure command is

./configure FC=ifort MPIFC=mpif90 --prefix=/usr/local/openmpi 2>&1 | tee

so I am using the ifort compiler. I attached the output files

I am using mpich-3.0.4 on Mac OS 10.8.2

I set the following paths in my .bashrc file

PATH=/usr/local/openmpi/bin:$PATH ; export PATH
LD_LIBRARY_PATH=/usr/local/openmpi/lib:$LD_LIBRARY_PATH ; export

any help is highly appreciated