Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Problem building OpenMPI 1.6.4 with PGI 13.4
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-05-29 17:31:58


Edwin --

Can you ask PGI support about this? I swear that the PGI compiler suite has supported offsetof before.

On May 29, 2013, at 5:26 PM, "Blosch, Edwin L" <edwin.l.blosch_at_[hidden]> wrote:

> I’m having trouble building OpenMPI 1.6.4 with PGI 13.4. Suggestions?
>
> checking alignment of double... 8
> checking alignment of long double... 8
> checking alignment of float _Complex... 4
> checking alignment of double _Complex... 8
> checking alignment of long double _Complex... 8
> checking alignment of void *... 8
> checking for C bool type... no
> checking size of _Bool... 1
> checking for inline... inline
> checking for C/C++ restrict keyword... __restrict
> checking for weak symbol support... yes
> checking for functional offsetof macro... no
> configure: WARNING: Your compiler does not support offsetof macro
> configure: error: Configure: Cannot continue
> + '[' 1 = 0 ']'
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/